Hibernation does not work, but sleep runs just fine

So for a couple of weeks ago I split my C drive into 2 partions so I could dual boot with linux on my Windows 7 machine. It all worked out fine except that Hibernation (not to be confused with "sleep") stopped working. I took a video of it, first I show the sleep mode working fine and then the non working hibernation mode.

I have checked possible things that could wake it in cmd but there is nothing. The computer does not even seem to enter hibernation at all so it has nothing to wake up from. It has worked fine before and I don't got any new drivers.

Try setting up a bigger page file. Due to you resizing your partition, the page file might have been corrupted, or is just set to small. Your page file should be at least as big as your RAM + a few MB more, since when hibernating, Windows dumps the RAM in the Page file. (It might be that I mixed up the sleep modes. If so, just ignore what I wrote above).
This thread might also help:

Actually it dumps the RAM into hiberfil.sys not the page file. Windows is best at managing it's own page file. You only really needed to adjust the page file manually pre windows XP on systems with little RAM.

The key is to make sure you have enough disk space on your windows partition to hold an entire RAM dump into your hard drive. So If you have 16 GB of RAM you need more that 16GB of free space on your windows partition.

you can reset you hiberfile.sys if it became corrupt

from a command prompt as administrator.....
powercfg.exe /hibernate off

reboot (shouldn't have to but I like to)

powercfg.exe /hibernate on

See if that helps your issue.

1 Like

This actually fixed it, thanks alot! Been troubleshooting this forever, thanks again! :)

Glad I could help.