Help with testdisk

I have a small problem, I accidentally formatted one of my drives in Windows.

PhotoRec finds the partition, but Testdisk doesn’t.

Help would be really appreciated.

I’ve tried everything I thought of, even manualy changing the partition type to linux, and the filesystem to ext4

what exactly are you trying to do?

Recover the data?

1 Like

Yes, testdisk is for recovering partitions/data without having another disk to move them to. It worked once before on another disk. But it doesn’t work this time. I don’t have another HDD at 4TB

But I find it weird that PhotoRec finds the partition, and not just loose files. But TestDisk doesn’t find anything.

UPDATE: I can find the partition when searching for non-partitioned media. But I can’t write when searching for that.

EDIT: It also finds a few superblocks in non-partitioned mode


I went to superblock while in non-partitioned mode. and then it just told me to use a command, here’s it:

fsck.ext4 -p -b 163840 -B 4096 /dev/sde

in case anybody from the future reads this. 153840 being one of the superblock numbers, 4096 being the size and /dev/sde being the drive.