Help with odd keyboard issue

So I just built my new computer (all specs on profile) and everything works perfectly...stock. Of course I've got a K series processor to overclock. The issue is, whenever I go into my bios, change any value, save and reboot and get back into windows, my keyboard doesn't work.  Also, windows takes almost twice as long to boot when this is done. Unplugging and replugging the keyboard into the same usb port does not fix, nor does changing to any of the other ports. The only fix is to shut down and restart my rig, not entering the bios, and bam! keyboard works as regular windows startup speed. I have not tried with a standard usb keyboard (my mech5 functions the same as a basic keyboard anyways even without the driver which only enables key re-mapping) but I doubt this would help. This is a repeatable issue and seems related to the bios. Some other settings in click bios II seem buggy as well, such as being unable to 'click' the cpu multiplier to adjust it. The only way is to highlight it, and use the spacebar to increase value 1 step at a time. This issue seems to stretch across any of the 'delicate' settings in the bios dealing with voltages or timings, because I tried changing most for testing purposes. Also haven't tried switching over to the second bios, but I did clear cmos to ensure I was at stock settings. This is more of a quirk than a problem, because obiously after doing a restart within windows the problem is gone forever until I adjust and save bios settings again. Any insight is appreciated.

knew it was a gd65 when i you started talking about the + and - incriments, i've got the same board with that same + and - issue. haven't had the keybaord boot problems though. msi implimented the incriment feature for god knows what reason but it's not a glitch. as fot your main problem i don't know how to help. my mechanical keyboard is running normal usb 2.0 none of the ps2 stuff. if you're running it in a usb 3 port that may be the issue, otherwise i have no clue

Thanks for the suggestion, but it is running off a 2.0 port. So really!? You're actually supposed to use the spacebar to increase values?? I see no way in that case to decrease the values if you go too I missing something if a certain key is for that? Also arrow keys can't adjust, which would just make way too much sense. As far as my expectation, watching the ncix tech tips video about overclocking with this exact board, Linus appears to double click the muliplier value, and a scroll menu pops up. Did they actually take this feature out then? I though I was missing a setting somewhere else you had to say, enable manual overclocking or something..

Well after some more exhaustive searching, I appear to have figured this out. I can't be sure though as I didn't do the right thing and only change one thing at a time..So I found that someone had said to disable USB as a boot option in the bios, so I went in and cleared everything except for my ssd and the uefi bios from boot options for now. Saved and exited, and computer still did its weird thing where it takes twice as long to boot compared to normal. So this time, any of the 'extra' keys on my levetron mech 5 worked..the calculator hotkey build in, and even my custom assigned 'A/B' key for notepad worked and opened the program. Keyboard itself still wouldn't type any keys or numbers, from the main part or the attached numpad. After waiting for about 30 second to see if it would initalize, i pressed the 'A/B' switcher key which switches between the 2 functions available for the 5 customizable keys, and lights up the LED behind them. Immediately I could type again. So I'm unsure as to whether it was this switch, or the bios setting that did it. I've confirmed by going back into the bios and enabling an xmp profile to the same specs as my stock memory, saving and exiting, waiting for the double long reboot, and violo! All keys on the board worked immediately, custom keys and standard alike in notepad. Still a very strange occurance,