Help with Lenovo T440s Battery Charging Problem

Hi all!

I don’t know if this is the right section for this, but I have a problem with my ThinkPad T440s and would really appreciate some help. I recently bought the laptop refurbished and it is pretty nice except for one thing - the external (removable) battery is not charging at all and the internal one is not charging past 80%. Both show as “Not Charging”. :slightly_frowning_face: Has anyone else had that and know how to resolve? To me this lookes like a software problem and not a hardware one. As far as I can tell I have updated/installed all the Lenovo drivers and utilities. I’m running Windows 10 Pro, incase thats relevant.
If I remove the external battery, the internal one will charge to 100% just fine. I don’t have a multimeter handy to check if the external battery is in fact fine, but Lenovo Settings utility shows both battery conditions to be good. I have found that this has hapened to others, but the solutions I have seen so far have not worked.
Things I have tried so far (in no particular order):

  • Googled (DuckDuckGo actually :stuck_out_tongue:) the problem and looked at Lenovo forums, reddit, etc.
  • went through BIOS settings
  • updated BIOS to the latest version
  • removed/reinstalled the battery (turn it off and on again :wink: )
  • reinstalled the battery ACPI Windows 10 drivers.
  • did Gauge Reset with a Lenovo utility (that errored out)
  • tried setting custom charge thresholds
  • booted to Live Linux USB to see if it would charge then (it didn’t)
  • tried charging it shutdown to see if maybe the 45W charger is not powerful enough (still the same thing)
  • probably some other minor poking around that I have forgten about

So far nothing has fixed the issue and if the problem is in fact a softrare related, I should be able to resolve it myself (if I could figure out how) and avoid taking the laptop to a repair shop.

Anyway, any ideas on how to fix would be appreciated! :slight_smile:

Sounds like the battery is just gong bad.

Li-Ion batteries degrade over time. I’ve had one for about 2 years and the battery capacity is at 80% of what it used to be; this is to be be expected.

But since the battery won’t charge, that means it’s either going totally bad, or the mechanism which allows the battery to charge is faulty. Which warrants a mother board repair.

Thsi is what the Lenovo Settings app gives me on the removable battery

The cycle count is not even that high and the shown Full charge capacity is pretty OK. Also, I might be wrong on this, but since the battery is detected and all the stats can be viewed I assum that the charging cicruit isn’t completely dead.
Also like I said, the charging problem is only there if the secondary removable battery is inserted. If I remove it the internal one charges completely fine to 100%. This leads me to believe that the problem is software/firmware based and that some driver/other program is preventing a normal charging cycle.

Also, I just tried disconnecting the CMOS battery, to reset the BIOS. It was reset, but the problem is still present.

typically Li-ion batteries last ~500 cycle counts.

Since the issue remains on different platforms, then see if you have a BIOS update. If you don’t then I don’t know how to help you further.

Hmm the external battery could indeed be dead. Sometimes having a battery siting around for a long time and not being used at all is really bad for them.

The fact the internal one is only charging to 80% when an external one is fitted would be a software life preservation thing. The batteries last much longer when not fully charged all the time. However, with no external it will be trying to give you maximum life.

The only way to fix it might be to crack it open and directly charge/recondition the batteries using an external charger. That might work, but if you are not carefull could also be danergous!

Does the charger power on the laptop without the battery(s) installed?

Also jumping in even tho this is old.
Usually when the battery doesn’t hold a charge or charge at all, the issue is just one dead cell, so if people are up to the task, they can replace it themselves.

I have a lenovo t440s that I have replaced the internal battery in but the OS does not recognize it even though the battery can run the machine by itself.

Any thoughts on what is going on here?