Help with Aorus TRX40 Xtreme 3970x Build

During the last 3 to 4 months I have been knee deep into building my own custom PC spec list to follow bellow. After intsalling the Corsair Hydro X custom cooling loop for my 3970x I began the final assembly on the PC. Got every thing setup for start up and nothing. Couldn’t even get any lights to come on on the MB, RAM, Custom Cooling Solution, even the PSU didn’t start which I found weird. So I backed tracked and started disassembly and testing as follows:

  • Unhooked PSU and tested using jumper from my hydro X kit (had just completed 24hr leak and air test of cooling loop.

  • Checked connections to and from MB leaving only RAM NVME CPU Cooling and CPU attached. Still got nothing even used on board power button on the board itself.

So called up Gigabyte for Repair on said board and sent it back for repair. Found out today that on their end that the board according to them is fine when tested with multiple set ups.

My Question is what else is next as since I don’t have a test bench and can’t really test RAM or CPU without a board?

PCPartPicker Part List:

CPU: AMD Threadripper 3970X 3.7 GHz 32-Core Processor (Purchased For $1899.99)
Motherboard: Gigabyte TRX40 AORUS XTREME XL ATX sTRX4 Motherboard (Purchased For $849.99)
Memory: Corsair Dominator Platinum RGB 64 GB (4 x 16 GB) DDR4-3600 Memory ($669.99 @ Newegg)
Storage: Kingston SSDNow V300 Series 120 GB 2.5" Solid State Drive
Storage: Samsung 850 EVO-Series 250 GB 2.5" Solid State Drive
Storage: Samsung 860 Pro 1 TB 2.5" Solid State Drive ($299.99 @ Newegg)
Storage: Samsung 970 Evo Plus 1 TB M.2-2280 NVME Solid State Drive ($219.99 @ Newegg)
Storage: Western Digital Caviar Blue 500 GB 3.5" 7200RPM Internal Hard Drive
Storage: Western Digital Caviar Blue 1 TB 3.5" 7200RPM Internal Hard Drive ($45.99 @ Newegg)
Storage: Western Digital Caviar Blue 1 TB 3.5" 7200RPM Internal Hard Drive ($45.99 @ Newegg)
Storage: Seagate 1 TB 3.5" 7200RPM Hybrid Internal Hard Drive
Storage: Seagate 2 TB 3.5" 7200RPM Hybrid Internal Hard Drive
Storage: Seagate BarraCuda Pro 12 TB 3.5" 7200RPM Internal Hard Drive ($493.99 @ Newegg)
Video Card: Gigabyte GeForce GTX 1080 Ti 11 GB AORUS Xtreme Edition 11G Video Card
Case: Cooler Master HAF Stacker 935 ATX Full Tower Case
Power Supply: EVGA SuperNOVA G2 1300 W 80+ Gold Certified Fully Modular ATX Power Supply
Operating System: Microsoft Windows 10 Pro OEM 64-bit ($149.99 @ Newegg)
Monitor: Dell AW3418DW 34.1" 3440x1440 120 Hz Monitor
Keyboard: Logitech G910 Orion Spectrum RGB Wired Gaming Keyboard
Mouse: Logitech G502 Proteus Spectrum Wired Optical Mouse
Headphones: Logitech G933 Artemis Spectrum 7.1 Channel Headset
Custom: Corsair Hydro X Custom Cooling Loop (Purchased For $689.99)
Total: $5365.90
Prices include shipping, taxes, and discounts when available
Generated by PCPartPicker 2020-04-14 21:39 EDT-0400

Take a lot of pictures of your setup? And post here.

Remove all the cables from the PSU if modular and carefully reinstall before plugging into your case. Sometimes won’t post is a short in a modular PSU. Cable that only presents when plugged into a Mobo.

1 Like

If trully nothing happens no lights on the board,
no fans spin up nothing.
Then i personally would start checking power connections.
Or double check if the psu works actually works.

Sounds like a power / psu issue to me.

PSU worked as I took it out of another PC build with a FX9590 and is the same one that I used to do a 24hr leak test on my water cooling loop using a 24 pin atx jumper with the evga psu. I do have custom cables on it from cable mod but I’m using the included evga one’s for testing.

Just ran up to the office and set about testing my custom cables using a jumper on MB cables and extension cables they seemed to work fine so until I get the MB back from Gigabyte. Curiously when I talked to Gigabyte Tech Support they told me part of their repair process is to update the MB with the latest Bios. It was after that they said it worked for them then it went for testing and was found to handle any setup they put it through. So at this point I can’t move forward until the board is back.

Flashing BIOS helped with my MB (also TRX40 Aorus XTreme).
However, in my case I had a clear indication that some power is being delivered (postcodes were displayed and PSU fan was spinning).

It seems that as of 5:10pm EST after talking with gigabyte again that the problem with my MB was a broken factory applied Bios that wouldn’t let the board post or display and indication of power getting to the board. Or rather thats the story I’ve been told from tech support this evening as my board ships out today. Not sure if that’s what was really wrong but I’m no expert when it comes to software so heres to hoping everything goes well when I get the board back.

1 Like

Images from Gigabyte Repair Center:

If there ever was an explanation, that’d be it. Wonder how they got it past QC tho. I guess mistakes happen eventually. Congrats on being that 1 in 1000 or 10000.

1 Like

I feel like I should get some sort of achievement for this @CybeastRaystriker. Seriously the 1 in 1000 in these boards at this price point and I got the one with a bad factory bios. Wish I was the one who got sent 2 motherboards by mistake when I only paid for one like tech who told me to go TRX40 platform.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.