Help Uninstalling a Program

So here's the story. I bought some 3DS with a capture board installed probably back in February from Japan. It worked for a long time, but then stopped connecting to my PC a few months ago. I connect through mini USB to a USB 3.0 port. I also had to install some driver and program to get it to show up on the PC.
One day when I plugged it in, it said the device malfunctioned or what not. Now it's not recognized anywhere. I contacted the manufacturer, but this dude is taking forever. The last time he responded, he told me to uninstall everything and try to reinstall it. This was after a few other options. When I tried to uninstall one of the programs, I got this error message:
I asked on Linus Tech Tips. One of the forum members said I should try using CCleaner. I tried, but got the same message.

If you have another PC I recommend trying to use it on that see if its the board that might have went bad. So you don't go through this trouble for nothing.

Anyway I'm assuming the program in question is Cypress with all those drivers. My solution would to brute force remove the program, BUT considering it has drivers that might not be the best course of action. Says there is a missing ini file try and replace it. Doesn't have to be the actual ini file that came with the program just random file named the same thing. Also some program installers have a repair option. Maybe download its installer and see if it over writes anything then try uninstalling it. Also try uninstalling from safe mode as well. Another option would to try a different usb port, I have a Mic that just randomly refuses to be recognized by Win 7 sticking it in a different port normally works for me. The only other safe idea I have is to use Revo Uninstaller it basically removes any traces of the program from the computer. If that doesn't work I would just force delete the programs associated files then run CCleaner. Hope this helps.

I connected it to another laptop and it said the device malfunctioned again. A little pop up came up on the bottom right. I had tried different USB ports before with no luck.


The installer doesn't seem to have a repair or uninstall option either.

If it malfunctioned on a different computer I would just assume the device is broken. Try a different USB cord maybe? IDK what the guys policy is on returns for 3DS Capture cards. Maybe ask him if there are Linux or OSX drivers and try it on there (I remember seeing a forum post about it back in 2012). As for the installer see if it will just let you overwrite its files. Basically just keep hitting Next on the installer and let it do its thing.