Help! stuttering issues in game

im getting stuttering issues in game mostly happens right at the beginning of the game or 3d mark then goes away. ryzen 5 2600 overclocked to 4.2 ghz 1.4v stable ram corsair vengeance rgb pro 3000 overclocked to 3200 mhz 1.4v stable. and b450 tomahawk motherboard, coolermaster gold rated 750w modular psu and a msi gaming z rtx 2070 video card. please help.

1 Like

could be disk IO still loading assets at the start of the run.

how much RAM do you have? does it do it every time, or only the first run after a reboot? disk cache is a thing and if you have enough RAM then you’ll have plenty of disk cache. if you only have 8 gigs, then you’re less likely to get as much caching happening.

32gigs says the profile.

When did those stutters start? Did you change anything lately?

32gb 2 sticks of 16gb of ddr4 corsair vengeance rgb pro 3000 mhz

the stuttering has pretty much been going on since i built this pc. as far as i can remember. im thinking it might be a bottleneck of some sort.

Check GPU drivers / windows for updates. If that doesn’t help reset BIOS to defaults, check for updates on that, disable C-states and efficiency stuff. In that order.

ive done all that except disabling c states. how do i do that again in the bios?

Uuuuuuuuuuhm … you find the thing that says C-states something and set it to off? :yum:

Check what happens when you disable CPU Core 0 for your game.

1 Like

why? what would that do?

what exactly will disabling c-states do?

Windows tends to load EVERYTHING on core zero, the system, all applications and games main threads.

If you set games to not use it they get shifted to a less used core for their main thread and might run better.

Windows is still terrible at managing anything other than a single core.


C-states are different levels of CPU activity … kind of, specifically in idle. It’s mainly for efficiency. P-states are the equivalent under load.

So disabling that management will keep the CPU active under all circumstances.

Bad distro, wouldn’t recommend.



ok cool, ill disable c-states

wont i also loose a core as well?

Yes and no.

You’ll have another core getting the heavier loads, probably will stop the stuttering if that is the issue.

Are you using SSD or HDD? What brand and model? Which version of windows?

Not really, the rest of the system continues on as normal. If an application uses multiple threads the main one gets started on Zero and all the threads that it creates get pushed to other cores but still rely on the main thread on core Zero to tell them what to do. If core Zero is busy because it is doing this same handling for every other task too it will sometimes have to wait for free time and this causes potential bottlenecks.

If you tell a specific application not to use core zero it will start on a different one (which just by its nature is not as heavily loaded because it is not core Zero) and will have more free time to handle whatever is running on it. It will still created other threads on other cores and manage them from its new starting core.

This is where my understanding breaks down. That specific application will not use core Zero so technically it has one less to use. The part I don’t know is this, I am not sure if when every other core gets loaded up by the application ignoring core Zero will it then use Zero because its the last still free core.

But that vast majority of games will not use more than a few threads and you have 12 available to you, 10 after ignoring core Zero. It would be nearly unheard of for a game (other applications maybe sure) to load up 10 threads and still need more, or if it gets that far for it to be of any realistic impact not to use 2 more.

Edit: I should point out that this is just my “advanced normie” level of understanding I could be wrong and I hope someone clarifies if I am.

1 Like

Like others said:

  • In Taskmanager or Process Explorer, set process affinity of your game to not use CPU 0 and 1 (because SMT)
  • Check drivers (WinKey + Pause > Device Manager), yellow triangles are bad. You could be missing a chipset driver.
  • Update Nvidia drivers, maybe you had a bad install, maybe Windows10 decided to fuck with them.
  • Use Ryzen Master or similar to check CPU temperatures and frequencies.
1 Like

Nobody tells you to castrate cpu with a soldering iron. I just suggested you check if something changes.

The only thing you change is one core less only for a given process (game) the rest of the system and other applications still have all cores at their disposal.

Anyway, it’s not certain that this solution will fix your situation. Just do it if you want to do it. You would have done this test faster than writing these posts. :wink:

1 Like