[HELP][SOLVED] Unable to locate gitlab-ce

I pressed the reboot, and now it is blackscreen. I closed it.

Sometimes you need to give it a few minutes to boot.

Black screens for a moment or two are normal.

1 Like

good

Well, it seems that I have installed the nogui version :slight_smile:

Did you want to install the gui, or are you happy with the terminal? (GUI won’t be necessary)

I feel pain right now. But If i can upload and manage all the files from outside centos, then everything should be fine.

1 Like

That’s definitely going to be possible, once gitlab is installed.

so proceed as planned?

Yep!

my account seems not be a sudoer, I have no idea what that means but I guess I have no admin rights. I did not add them to the account but I still have root password n such

it will be easier if you just type su and enter the root password. su switches users and by default switches you to root.

From there, you should be able to finish the guide

cannot find a valid baseurl for repo: base/7/x86_64, btw should I do the sudo yum or should I go for the link

For which step? You should be copying the code basically as is (although you can leave out the sudo part because you are root)

sudo yum update -y
this code bit didn’t work out. but I’ll try the link you sent

Never mind, I get the same error doing:
sudo yum install -y curl policycoreutils-python openssh-server
cannot find a valid baseurl for repo: base/7/x86_64

if that didn’t work then you might have network issues. try running ping https://forum.level1techs.com or any other website that you know is up

I should have perfectly fine internet, cannot ping that link.

1 Like

Apparently you might have to run sudo dhclient on minimal centos installs

https://imgur.com/a/2BGElI9 I ran the dhclient. I somehow I always manage to fup

try running ip addr | grep inet | grep -v -e inet6 -e 127.0.0.1 to see if you are getting an IPv4 address