HELP: Ryzen 9 + ECC RAM from Asus QVL no POST

Good day to you,

I have a problem with my new setup: the system does not POST with a single ECC ram stick from mb QVL.

Specs:

  • asus X570 ProArt Creator WiFi (bios 0801)
  • ryzen 9 5900x
  • Micron MTA18ASF4G72AZ-3G2B1 32gb ddr4 udimm
  • radeon 6600xt nitro+ (sapphire)
  • a 256gb nvme drive in M.2_3 slot (win 10 on it)

I also have a spare regular stick of ram from Kingston with which I can boot os/enter bios.

Description:
When powering on with the Micron stick in any of the dimm slots, I get a solid dram led and no post.

I tried:

  • all possible ports of dimm, graphics card, re-seating the cpu
  • lowering dram freq from 3200 to 2666
  • disabling ecc ram support (auto/enable by default) seems to help in passing the memory POST, but leads to a reboot cycle without access to bios.

Can you please share some tips on what can I do? perhaps change something in bios? Unfortunately I don’t have a 2nd ecc ram stick to check or some other system to ensure the ram stick I have is indeed working.

Many thanks.

I can’t think of anything, but for good measure I double checked your RAM/CPU/MB/BIOS support on the ASUS website and it all checks out. Definitely seems like it should work.

Since the CPU and GPU seem to work fine with a different stick of RAM, I’d say that rules out issues with those parts of the puzzle. Have you tried a factory reset on the BIOS?

EDIT: It is possible you just have a bum stick of RAM. It’s rare, but does happen.

Join the club!

I only know this, because I was trying to get my Home Server configured as such.

I tried 4x 32GB 2133MHz CL22 ECC DIMM’s w/ a 3800X and ASRock B450m Pro4 board…no boot, not even a single DIMM.

…okay, odd, claims ECC support.

So, I pulled the RAM out of my 5900X and MSI Creation X570 board, and put the ECC DIMM’s in there.

…and again, no boot, no post.

The F*#@?!

Not sure the issue, but ECC ain’t working for me, at least 32GB ECC DIMMs, not in 400 or 500 series.

The DIMM’s I used, do work, as they’re now in a Chinese X99 reused chipset board with a Xeon 2697v3, all 128GB’s w/ no issues.

If it’s on the QVL it might be time to reach out to Asus support. First level sucks but if you brow-beat them enough they’ll eventually put you in touch with an engineer. Which reminds me, I need to go flash a beta BIOS on my ProArt X570 to see if it fixes SR-IOV…

1 Like

@GeorgePatches, I haven’t tried factory reset, guess it’s worth a try.

@bambinone, that’s what I did few days ago. They managed to satisfy their 48h deadline by replying smth along the lines of “we are aware of your request, will be back in a couple of days”.

@HopnDude, my hope is that the micron dimm works and perhaps some fiddling in the bios options will allow me to use it. Perhaps someone walked this path of dark wizardry here. If not, I’m afraid brute-forcing is beyond me (and the dimm slots’ resource).

Just as a FYI to those saying ECC doesn’t work, I’m currently 4x32GB ECC UDIMMs in my system with zero issues. Maybe it’s because my ASUS Pro WS X570-ACE is a “workstation” board so they put more effort into making ECC work? Or maybe it’s the Kingston KSM32ED8/32ME DIMMs I sourced from CDW to be sure I was getting non-counterfeit DIMMs. I don’t know, but it’s working fine for me. Just one datum for the pool.

1 Like

Got a very similar setup with the ASUS ProArt X570-CREATOR WIFI with a 5950X and 128 GB Micron DDR4-3200 ECC UDIMM.

In addition what you’ve already tried I’d do:

  • Remove the CMOS battery for 10 min
  • Reseat the CMOS battery
  • Use the USB flashback feature to completely reflash BIOS 0801

If this doesn’t change a thing, reseat that other DIMM that works, go into the UEFI and check some voltages.

For some unkown reason the default auto voltages on the ASUS ProArt X570-CREATOR WIFI have been pretty low, my auto CMOS default DIMM voltage is around 1.15 V. It could be that depending on the individual DIMM tolerance that this is too low to initialize the memory properly.

3 Likes

AMD RAID! You’re brave. :wink:

The only possible solution if you want Windows to live on a RAID1 volume if you don’t want to senselessly sacrifice PCIe lanes for a RAID controller.

But it could be better (but here I’m at least using an NVMe RAID1) :wink:

2 Likes

@vigr I got ahold of some 2133MHz (mt/s) CL22 ECC SAMSUNG DIMM’s.

I looked at documentation, and these SHOULD work according to documents, but didn’t.

(solution for me)
Either way, I went the Xeon route, because I was having too many IRQ issues on the 3800X (and would with any other prosumer solution) with all the slots filled out, and hammering on the system with device request.

On the ASRock B450m Pro4 board, I was running a Nvidia Quadro P600, AVerMedia Live Gamer 4k, LSI MegaRAID card, and Fusion ioScale 3.2TB PCIe SSD (how many slots does that board have, and how do you think I got those to work).

I found a Chinese X99 board that just FIT THE BILL, P-E-R-F-E-C-T-L-Y! for all the cards I was using, with full fat PCIe bandwidth to each.
(/solution for me)

As for your ECC issue, I’ve had similar, but with no resolve. Sorry you’re having to deal with it, and best of luck.

The source of your issues seem to be there:

X99 does not support 32 GB ECC UDIMMs, if you use 128 GB there with four DIMMs these have to be either registered or load-reduced ECC DIMMs. AM4 can only use unbuffered (ECC) memory in general.

3 Likes

@aBav.Normie-Pleb this is a really good catch. I fired up my ASUS WS machine and checked my voltages. It’s running at a rock solid 1.192v, even under a memory stress test. That seems like a really solid line of investigation.

Well, I guess that would solve what my issue was then.

User Error found.

Have a few Pro WS X570-ACE and ProArt X570-CREATOR WIFI units and the ProArts are the most extreme I’ve ever seen regarding voltages (DIMM, Chipset/SoC) lower than they should be. Messaged ASUS’ Support about it (the first couple of UEFI versions for the ProArt were horrible, currently with 0801 I’m not experiencing any issues anymore), no changes in almost a year regarding the low voltages.

But you can manually set the various voltages and it then uses them correctly.

I’ve had so many weird issues with those boards, with the Pro WS requiring more VDDG to be stable; and the ProArt not rebooting with an Intel 82599 card in the PCIEX16_3 slot and SR-IOV enabled, and not negotiating Gen4 for certain drives in the M.2_2 slot. Overall though I’m pleased with them, though.

Uninformed question, what’s VDDG? I’m running a Pro WS and I’ve had no stability issues that I’ve noticed. I’ve only had one since June of '21 though, so if there were issues before BIOS 3402, I wouldn’t have seen them.

It’s one of the voltage knobs for the Ryzen SoC. I have VDDG CCD set to 1.1V and VDDG IOD set to 1.0V.

1 Like

Interesting, @aBav.Normie-Pleb, the only difference I see is that you just have 4 sticks of ram instead of 1.

Increasing Vdd to 1.3 didn’t help. Neither did resetting bios. Disabling some sort SPD Optimization (‘read the whole 512 bytes’ or alike) didn’t either.

Guess I will fiddle with Vpp as well and poke around other settings.
Btw what are ‘DRAM UECC Retry’ and ECC symbol size?

  • Checked today, can also use just a single Micron ECC module without any issues.

  • To be sure, you also did the step with the USB flashback feature to reflash the BIOS while the system is off and not just the CMOS battery reset?

  • Can you verify that the Mircon ECC module is working at all with another DDR4 system? It should just work in systems that can’t do ECC, the ECC functionality gets ignored then.

  • You checked the model number sticker on the module itself that it is in fact an ECC unbuffered module and not a registered/load-reduced one?

I have seen retailers that accidentally shipped registered modules even though the customer ordered an unbuffered model.