Help Requested: Trying to rule out ISP Fuckery

Edit #2: SOLVED. Thanks @Dexter_Kane + @The3Zone

Edit #3: NOT SOLVED. DAMMIT. I can receive just fine with the DNS change, but I still can't send from either account.

Hey everyone.

I'm having some issues with my email client. Normally I use Postbox but now next to nothing is working. I've got no idea wtf is up, but here's some foundational stuff:

2 email addresses
-NameCheap cPanel

2 clients tried
- Postbox 3
- Thunderbird

2 hrs spent on the live chat with an NC rep, tried their best to actually help me.

No Avast! firewall. Attempted with Windows Firewall off and with Postbox & Thunderbird "allowed". Tried with modem firewall both on and off.

Webmail works fine, but I really don't like webmail. (I use POP3 on my desktop and IMAP on any mobile devices I happen to be using, which is usually 0.)

I have no idea where to go from here. Please help me out -- I'm suspecting ISP fuckery, but I'd like to either rule that out or be able to show them I've done my due diligence.

Edit: I have attempted it with both SSL/TLS and STARTTLS with each address under each client in all the firewall states. No dice there. I have also tried to allow post Postbox and Thunderbird to autodetect the connection settings for each account, and they fail out, again, in all the states. Thanks @Th3Zone for reminding me to post these.

Have you tried to switch to POP3S or POP3 over STARTTLS? I suspect that G-mail does not accept unencrypted connections anymore; so I would expect it from namecheap;

What if you create a new (duplicate) account in Thunderbird for access in gmail for excample and let it determine how to connect to the POP3/IMAP and SMTP server(s)? Which services and ports does Thunderbird pick? Does the connection fail or does authentication fail?

Actually I've tried both SSL/TLS & STARTTLS for both emails in both clients for all the firewall states.

I don't really want an insecure connection, so that was logical.

As far as allowing either client to autodetect the server configs, neither is able to do that with confirmed good address & password (I use Lastpass, so I manually confirmed).

Probably should have mentioned both of these in the initial post, sorry.

Have you tried using a different DNS server?

1 Like

Nope. Off to do that now, will report what happens.

Actually, that got one of the two addresses to work in my preferred client. Now I just have to get Gmail to work through POP3, thanks.

As a side note -- damn that really seems to make a difference in general. ISP must have really quite bad DNS servers, worse than I thought anyway.

are these the settings you're using when setting up your gmail account?

Email Address: Enter your full Gmail email address
Password: Enter your email password
Incoming Server:
Incoming Server Port: 995
Use SSL: Yes
Outgoing Server:
Outgoing server (SMTP) port: 587
Encryption: TLS

As you use gmail anyway.. you can use googles distributed DNS service: and its really fast, does not filter but most most most likely harvest your DNS queries

Yup, that's what I did.

Thank you, and thank @Dexter_Kane as well -- you fixed this for me in like 20 minutes. I had spent most of the evening on this.

No worries, DNS is a constant pain in my arse. So it's sort of become my usual suspect.

I never had any problems with ISP dns so far, except them fucking around with not resolved domains (due to typos) and offering their own add infected search there.

I by now run my own reseolver at home for local DNS and it resolves to the CCC DNS in germany, a DNS in swizerland, a DNS in the netherlands and if everything fails to google.

I do something similar except I use dnscrypt.

Google services are something I want to phase out of, and I'm working on just that, but damn. That should never happen.

Which resolvers do you use that actually also support dnscrypt?

I run dnscrypt-proxy on then configure bind to forward to it.

1 Like

@Dexter_Kane @Th3Zone Maybe you guys can help me out again.

So apparently I jumped the gun a little bit. I can receive now, but not send.

what are your smtp settings?

So I... fixed the cPanel email by staring at it's inbox.... I may be overtired and forgetting that I did something, but if I did I can't remember it. O.o

But Gmail is still being obnoxious. Here's my SMTP stuff.

Server: ( I also tried )
Port: 587
Auth: Encrypted password

are you using STARTTLS?

I can try that. Should I be?

Edit: Swapped it over. In Postbox, my options are STARTTLS or SSL/TLS, neither works without changing other details.