[HELP] Possibly me messing up or something else. Installing Arch to laptop

Hello. Hopefully this is the right thread to post this to.

So today I tried installing ArchLinux on my laptop. I checked my CPU architecture(Should be i686, CPU is Pentium 740) etc. So I created the live USB with Rufus. Everything worked fine, booted to Arch screen, where it would let me boot to the OS.

This far everything looked fine for me, even the overlapping of the text, since I experience this from time to time with the laptop. After a minute or two my screen turned pitch black with backlight not even working. It stood like this for about 10 minutes(I think) until I got impatient and pressed the power button.

After pressing the power button, this text came up. I don't know, if I should have waited or something, but it looked like my system was hanging. I don't know, if I'm supposed to type in something, because so far every Linux install has been smooth for me, at least on my main machine. I did try Linux Mint before on my laptop without problems as well.

Am I doing something wrong? Keep in mind, that I'm very inexperienced with Linux in general. I can include any other kind of information, if needed.

Sorry for my lack of grammar, if there was any.