Help! NVME SSD not detected on Gigabyte B550 AORUS ELITE AX V2

I just upgraded my 1600X to a 5800X, and got myself the Gigabyte B550 AORUS ELITE AX V2 to go with it. I swapped everything over, including my NVME boot drive, but this drive is not detected in the BIOS. I already tried upgrading the BIOS to F13i. I tried both M.2 slots (M2A_CPU and M2B_SB). I also tried changing the PCIE bifurcation to 2x8 as recommended by a Tom’s Hardware thread (can’t post links). I am out of ideas and getting desperate. I know the drive works since it has been my boot drive in my old rig and working fine. Am I missing something?
SSD is Samsung 950 pro 512GB, if that’s important.

I just tested a WD drive, which works fine. Did I brick my samsung somehow?

Samsung drives works in a USB NVME enclosure. Copied my EFI partition over to the WD and I’m up and running, but I’d still rather use the Samsung, if anybody has any ideas why it’s behaving like this

1 Like

I have not actually seen a BCLK option in an AMD BIOS but if there is one, and you or XMP set it higher than 100 MHz, NVMe drives can fall off the bus.

I saw this happen with an Intel Optane NVMe drive and a Gigabyte X99 board when BCLK was set to 103 through XMP (for some reason). Huge numbers of PCIe corrupt transfer errors and resets when it did boot and about half the boot attempts failed.

Thank you for your reply @zlynx. Do you mean XMP as in extreme memory profile? Sorry if I’m being a noob and this is something else. XMP is disabled and all my clock frequencies are auto (CPU is 3.8GHz, memory is 2137MHz, don’t see a lot of options besides that (pretty disappointing with this mobo so far honestly))

Put the Samsung SSD on another mainboard. This will tell you if your SSD is defective or if there is only some kind of compatibility issue.

@anon86748826 I just tried the drive in my old motherboard (Gigabyte AX370-Gaming K5) and it’s working. It’s also working in my USB NVME adapter.

When I first built my system in 2019, the X570 Master board didn’t see my Samsung 950 Pro either…just nothing in the BIOS. It works in another system though, so I didn’t go back to see if any subsequent BIOS have corrected the situation.

Hi @marceljoseph

Have you managed to solve the issue? I have an aorus elite b550 v2 and I experience the same issue. Motherboard BIOS simply doesn’t see anything. Everything is brand new.

1 Like