Help! Network Switch

I have my network set up with switches connected to a router. Right now I can get a network/internet connection directly though the router but if I use a switch (tried two) the network shows up a few seconds then crashes. Unplug the switch and plug it back in the same thing up for a few seconds then down again.

Running an internet cafe and this is costing me money. Please help :)

Is there some kind of loop in your set up? If you have more than one connection between the switch and the router (or any combination of devices which creates a loop) then this will cause it to crash.

You need to use a crossover cable to get two switches to talk to each other.
switch to router needs a crossover cable

I have three switches connected into one that is connected to the router. It has been running fine for around 10 months that way though. All unmanged switches.

Not with anything modern, most devices (all gigabit devices) are auto sensing so there's no need for crossover cables.

While the network is non-functional through the switch, is it still functional directly from the router?

I assume you've tried restarting everything? So you can access the internet when connected directly to the router but not if you use any of the switches?

The first intermediary switch was a gigabit (Cisco SG90D-08) the second is a SF90-24 100MB

Yesterday was the first time this happened and today it wont stay up. Tried different computers for servers traded out the two primary cables. At a loss here.

Yes restarted everything even shut down the breaker since I thought it was a virus. Correct can talk to you on the three we have plugged into the router but nothing through a switch at least not long enough to do anything.

Can access the router if plugged direct but not if I go through a switch.

what duplex mode is set? full or half?

Duplex full

I'd try unplugging everything from the switches so it's just the switches and router which are connected and see if you're still getting the same problem. If it works reconnect each device one by one and see if one of them is causing the problem.

Well we unplugged everything and connected to the router through the switch then connected each one, one at a time and now their all connected and working again. Don't know why I didn't think of that. Would really like to know what was wrong but its working at the moment. Hope it stays up.


Could have been some weird issue with the ARP tables or something, who knows, glad you got it working.

Sounds a bit like port security was enabled on the router where it restricts the number of MAC addresses allowed on a port. But not knowing the model/brand of the router I do not know if it even supports it. Glad it's working now though.

Don't you just love that warm fuzzy feeling after things just start working again for no apparent reason? :)