[Help] Need help to figure out why my vm playback does not work :/

Hi all :slight_smile:
so last system with win10 worked great.
Followed: Using JACK and PipeWire - Looking Glass

This time i have a problem with playback.
The Capture works great.
And the playback works if i manually connect it in qpgraph.

But i don’t get why my vm-conf only works on the capture?

if anyone can help i would greatly appreciate it <3

with kind regards

it’s a bit hard to help you when you have not shared any of your configuration details.

Edit: Also are you aware that LG B6 supports audio directly?

1 Like

sorry my browser was broken with the image upload :frowning:

and no i was not - that sounds nice :smiley:

but now that i have the problem i would like to fix (and learn) first.
ofc after ill switch to the better solution :smiley:

You are telling it to connect to a node that doesn’t exist, I don’t see a ALC1220 device in your graph at all.

it is the blue playback device in the lower right.
I tried its full name but accoring to pw cli ls the port is called

id 57, type PipeWire:Interface:Port/3
	object.serial = "62"
	object.path = "alsa:pcm:3:iec958:3:playback:playback_1"
	format.dsp = "32 bit float mono audio"
	node.id = "32"
	audio.channel = "FR"
	port.id = "1"
	port.name = "playback_FR"
	port.direction = "in"
	port.physical = "true"
	port.terminal = "true"
	port.alias = "ALC1220 Digital:playback_FR"

It’s not though, look at your graph. It’s called Family 17/19...


so this is what i want to connect to.

ALC1220 Digital:playback_F[LR]
ALC1220 Digital Stereo:playback_F[LR]
Family 17h/19h HD Audio Controller Digital Stereo (IEC958):playback_F[LR]
Family 17h/19h HD Audio Controller Digital Stereo:playback_F[LR]
Family 17h/19h HD Audio Controller Digital Stereo (IEC958) Stereo:playback_F[LR]

that are all the combinations i have tried so far.
non working :frowning: (last two were just brute force try and error)

the Full name was what i tried in the first place because my old system that worked :smiley:

Sorry mate, it’s been a while since I have used this audiodev.

I am not sure on why it’s not matching based on the patterns you have attempted, but I can say that it’s working for the input when matching on the device name, not the alias which tells me there is something janky going on.

The connectPorts is literally a regex, you could try something more generic like

ALC.*:playback_F[LR] or Family.*:playback_F[LR]

However since you’re using pipewire I suggest you just use the LG audio directly as it gives you more control anyway.

1 Like

yeah it is really strange that the capture works and it works when i manually connect it :frowning:

but maybe you are right and ill have a look into LGs new audio solution :smiley:
do you have a tutorial at hand or can i consult the wiki again ? (:

ALC.*:playback_F[LR] or Family.*:playback_F[LR] also did not work.
I have a feeling that there is a bug maybe because it is a digital output. My old system both where analog.
still weird that it works manually ^^

There might be, when I wrote this audio dev I wrote it against Jack, PipeWire did not yet exist.

The official LG documentation:


1 Like

thank you so much <3
for the help with troubleshooting as well as for the general development of looking glass!

1 Like

sorry to bring this thread up again ^ ^
i now notice a thing which i am missing.
On the old setup with pipwire/jack i could use my vm with input switched monitor for 12 bit hdr gaming. Now i need to have LG running for my audio to work.

Is there an option to get the audio automatically? Maybe set LG to listening mode and only start the “displayportion” when we don’t want to switch monitor inputs?

What’s wrong with keeping LG running? The host application capture process does not effect the pass-through GPU output. It’s not either/or. You can use your monitor with the VM GPU and also have LG running at the same time with no effect. With LG running in the background, you get Spice services such as mouse, keyboard and audio, and if you insist on reducing LG’s small CPU usage, you can always start LG and press ScrollLock+V to stop LG’s video rendering which will put the host application to sleep and practically eliminate any CPU load that LG has.

that is the workaround i have in mind.
but with pipewire/jack the audio connect was automatically.
LG does not automatically start when i start my vm :confused:
Or can LG auto start in minimized mode?

You can start the VM and LG together in a script on your linux system. If you minimize LG, you’ll lose mouse tracking and keyboard capture.