Return to Level1Techs.com

[Help]Issues Installing VMware Player on Fedora 29

linux
helpdesk

#1

Ive been trying to install VMware Player on Fedora 29. So that I can use my schools windows VM’s for some work. I tried setting it up using this guide:
https://sudobeer.com/how-to-install-vmware-workstation-12-on-fedora-26-linux-easy-way .
However I get this weird error:


I tried accessing the log file but i got an error that I didn’t have permission.


#2

Stupid question, can you use sudo to read/move/copy the file while VMware is completed closed?

Some checklist items I would check as well… (Not too familiar with Fedora, so bare with me)

  • Does the application have full permission to run? (chmod +X (vmplayer installer)
  • What happens when you try to start the service manually? (/etc/init.d/vmware start/status)

#3

If I try to sudo cd into the vmware-root directory in the terminal then the terminal doesn’t change directories, nor does it spit out an error. I already ran the bundle, but yea the bundle has permission to run.

[[email protected] Downloads]$ sudo /etc/init.d/vmware start /status

Output:
Starting vmware (via systemctl): Job for vmware.service failed because the control process exited with error code.

See “systemctl status vmware.service” and “journalctl -xe” for details.
[FAILED]


#4

I first tried VMWare Player (the free version) on Ubuntu 14.04, and it worked very well. Somewhat later I upgraded to Ubuntu 18.04, and my VMWare Player fell flat. I now associate those two things with the luck/unluck of timing, as you’ll see:

Some searching around led me to see that some module(s) required by VMWare Player ordinarily get automagically installed by the VMWare installation of update process (as you can see in the image that’s part of your original post – the “VMWare Kernel Module Updater”) but that, in some cases, a failure to compile and install a kernel module for a kernel that’s newer than VMWare has caught-up to does not show up as an error or a log entry.

The only solution I have found is to run with a kernel that’s old enough to have the required kernel module info available and released by VMWare. That mostly means keeping an eye on the release notes for each VMWare Player update, especially the date – and crossing your fingers.

It may be worthwhile for you to check the release date for your current kernel vs the release date on the version of VMWare you are using. If VMWare release date is older, you may have bumped into the same problem I have been having.

I’ve edited my GRUB config to do two things: increase the number of kernels it retains on update (I have always tended to make my /boot partition bigger than is probably necessary), and to present the list of boot choices for a longer duration (the default 5s is way too short for my aging brain/fingers combo), so I can manually select whatever kernel I know to work with VMWare player. BTW, I am more often using Fedora these days (28 at present), and the issue is the same, because it’s kernel-based, not distro-based. The release cycle for kernel updates so far has resulted in my remaining at least two, but usually three, updates behind in order to have a smooth VMWare experience.

Needless to say, this is annoying. It also means I tend to delay applying updates that include kernel upgrades, which is another whole issue.

I have tried switching to Gnome Boxes, but I was unable to get USB devices to pass through. I suppose I should have worked harder to solve that.

I have not tried oracle’s Virtualbox, but that looks like some weekend in the near future.

If anyone has more insight on how to better handle the VMWare Player kernel module update issue, please do speak up. My experience with vm’s generally goes waaay back to about 10 months ago … :wink:, so a veteran on this issue I am most definitely not.

F.Y.I.: the release date on the most recent VWWare Player is 2018-11-22
The kernel I am using that works with this this is 4.18.10