Return to Level1Techs.com

Help installing Nvidia Drives please!

helpdesk
elementary

#61

It’s just 3 back ticks or back quotes, aka ‘tilde’ key.
Then paste the output and close again with 3 back ticks.

image


#62

got it, thanks.

Edited the post above


#63

Ok that is definetly nouveau segfaulting here while running something from the nouveau_dri rendering library. And it’s doing so consistently at the same stack offset.

I recommend you try installing nvidia-304, since this is may very well be an actual bug within nouveau. Not sure if it’s old hardware related or in general an issue with steam & nouveau. I may test that at some point.

You can post the output of

systool -vm nouveau

To see if there might be a module config issue, but I doubt it.


#64

Ok, thank you :slight_smile:

I will run the instructions above to install and if necisarry uninstall the drivers.

But first I have to take my wife her lunch she forgot :slight_smile:

Be back in 20 minutes or so. Thanks for all your help.


#65

Take your time, I’m off to bed now. :slight_smile:


#66
 systool -vm nouveau
Module = "nouveau"

  Attributes:
    coresize            = "1716224"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "4"
    srcversion          = "DB23F79727F6A549DF527C4"
    taint               = ""
    uevent              = <store method only>

  Parameters:

  Sections:

#67

ran it and I get same error I got before. It won’t install with a version of xorg newer than 1.19.

I can try reinstalling mint, or installing an older version of Mint maybe that has the older version of xorg. I will go google which version of Mint has which version of Xorg before I do a reinstall.

sudo apt install nvidia-304
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-304 : Depends: xorg-video-abi-11 but it is not installable or
                       xorg-video-abi-12 but it is not installable or
                       xorg-video-abi-13 but it is not installable or
                       xorg-video-abi-14 but it is not installable or
                       xorg-video-abi-15 but it is not installable or
                       xorg-video-abi-18 but it is not installable or
                       xorg-video-abi-19 but it is not installable or
                       xorg-video-abi-20 but it is not installable or
                       xorg-video-abi-23
              Depends: xserver-xorg-core but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

#68

If you are going to try reinstalling, you might want to try MX17 Debian and try their nvidia installer tool. Debian should have GPU legacy driver support for long time yet

Just checked Live ISO and they have nvidia 304 driver

MX17 with XFCE is probably not at all like the sort of look and DE you would prefer
But if you get the hardware running right first, XFCE appearance can be reworked a lot
mac type look with dock (plank) added at bottom is not difficult
or install another DE, or another Debian distribution


#69

I apologize for my post. I just was trying to fix the blackscreen issue because it was something I knew how to fix on my machine.

I apologise, if I screwed anything up in this thread.


#70

You didn’t screw anything up. I’m learning on an old machine so that nothing can be harmed no matter what I do.

nikgnomic: I’m going to learn Mint or Ubunto if it kills me. Once I get Mint stable I’ll try Solus as others on here have been urging me to (in another thread).

I’m downloading Mint 17.1 now. I’m booted up in Windows7. Gosh it is sooooooo slooooowwwwww… It didn’t feel that bad before I started using Elementary. Even Mint seemed a little slow, but Win7 is an absolute snail.

Have I mentioned how much I love Elementary??? lol.


#71

Sooo… I got steam to run.

Downloaded Counter Strike Source.

Ran it,… error… Open GL driver needs updated…

Facepalm.

Here’s how I got it to run though:
Downloaded Mint 17.1
Burn to DVD
Installed
Ran Packet Manager
Searched for Nvidia
Found Nvidia-304 Driver in the list.
Installed
Restart
checked device manager and saw Nvidia-304 was driver running
apt-get install steam
steam

It worked… well, sorta.

I open terminal and “sudo X -version” and got:

X.Org X Server 1.15.1
Release Date: 2014-04-13
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-61-generic x86_64 Ubuntu
Current Operating System: Linux MintOS 3.13.0-37-generic #64-Ubuntu SMP Mon Sep 22 21:28:38 UTC 2014 x86_64

So with xorg 1.15 and Nivida-304 Steam will run on a Nvidia 6800 graphics card.

I don’t want to get into fixing the open gl driver now. This is just too much. I’m giving up and moving on to Solus as several on here have told me to. I really don’t want to run 17.1 Mint, Firefox is too out of date and won’t even install my default search engine “startpage”.

Maybe there is a way to uninstall xorg and reinstall older version in current version of Mint so I can install Nvidia-304 drivers? If so I might reaproach. But for now I’m more than overwhelmed and frustrated.

Thank you all for your help.


#72

Ok I have Solis installled as several on this forum suggested.

Installed steam and it did same stutter thing as in video above.

The hardware manager suggested I install the 304 driver. First Linux district to do that and already have it.

I did. Reboot. Now it switched to manual login and only displays terminal like full screen.

What do I type to make it launch the GUI???

Edit. Found it. Startx.

I type that and it says fatal server error. No screens found. Please consult the x.org foundation and check xorg.0.log

Grrr stupid xorg Nvisia problem again.

fixed it and back up. sudo eopkg rm nvidia-304-glx-driver did the trick.


#73

Well, that means you just removed the driver, so now you’re on opensource driver again. Gee I dont understand this. Unless the card really is just too old.


#74

Nvidia.com shows GeForce 6 Series as supported.

GeForce 6 series:
6800 XT, 6800 XE, 6800 Ultra, 6800 LE, 6800 GT, 6800 GS, 6800, 6700 XL, 6610 XL, 6600 VE, 6600 LE, 6600 GT, 6600, 6500, 6250, 6200 TurboCache, 6200SE TurboCache, 6200 LE, 6200 A-LE, 6200, 6150SE nForce 430, 6150 LE, 6150, 6100 nForce 420, 6100 nForce 405, 6100 nForce 400, 6100

It seemed to be loaded in Mint, but he moved to Solus without figuring out why CS didn’t work. Which could have been figured out with

glxinfo | grep rendering

#75

wow this thread blow up…Ok so I did not realize you are dealing with an old card that Nvidia dropped support for.

Can you try sth…Can you try and reinstall the 304 drivers on solus but before you reboot try and run nvidia-xconfig on the terminal (not sure if you need sudo or not)


#76

Honestly the best thing you could do to solve 99% of these issues, is to swap out the 6800 for anything more modern.
Something like atleast a nvidia 200 series or any ATi/AMD card.

I’m not saying you can’t run a 6800 with linux, it’s just that you’re going to make it exceedingly difficult for yourself as a beginner to deal with.


#77

I understand the problem perfectly.

If xorg 1.19 (or earlier) present plus 304 driver then steam works. (eg. Mint 17.1)
If xorg higher than 1.19 present plus 304 driver then Linux won’t boot.
If xorg higher than 1.19 present without 304 driver then steam crashes on launch.

Hope that simplifies. There are a lot of people with this problem around internet. No one has found solution other than what catsay said - buy a newer card.

Only way I know to get steam to run on this box boot to Win7 then it works fine or run old Linux version like Mint 17.1. Even then someone will have to go farther and figure out how to get open GL to work right.

Hope this thread helps other people on the net struggling with this problem.


#78

Will you be switching distros then? Is this a trial and error phase for you?

I wouldn’t want you to get discouraged from using Linux from this problem alone, although it seems like you’re over the toughest part already…it just didn’t work out.

I’m not one to throw shade at another distro but Ubuntu and its derivatives suffer greatly from being as disconnected from the core features that make Linux what it is. Did you ever try Solus yet? (I peeked in your other thread :stuck_out_tongue: )


#79

Not put off at all. I learned Mac and Windows by pushing them till they broke, learning to fix them, then learning to build/upgrade the hardware.

This is fun for me, though my frustration and concentration levels are not what they were 27 years ago in college…

I’m loving Solus and Elementary. Elementary is far and away my favorite. I’ve got solus looking like mac os with the main menu at the top and a bottom dock with a task menu just like mac and Elementary.

I’m actually typing to you right now in Solus :slight_smile: Once it was fully updated it is a lot faster. Elementary is the fastest, Solus just a hair behind, and then Mint a ways slower but still night and day faster than WIn7 on this machine. And I’ve been using Puppy to fix the computer when other distros crash and burn, so I like it for a recovery system running from CD.

When I get around to it I’ll start experimenting with Distros on my Mac Pro. It’s got 2 xenon processors and a much nicer graphics card. I’ll see if I can’t get steam to run on it natively in Linux then work on learning how to get wine to run my old windows games.


#80

This is so refreshing to read. Most people think Linux is complex because they cannot use it as efficiently as they can use the OS they are already familiar for 10 or 20 years. Which pretty impossible no matter how user friendly sth is. Nothing can compare to experience and most people tend to forget that they went through the same complex process years back when they were younger and learned to use Windows or Mac OS.