Help installing linux with the GA-990FXA-UD3 (rev. 4.0) motherboard

Well... where do I even begin? I really should have done more research on this subject but I'll admit my ignorance is pretty high when it come to Linux. I never thought to even research to make sure my board would be "compatible" with Linux I just assumed all hardware would work perfectly out of the box with it. I've searched around the Tek Syndicate forums as well as googled many times the issues I am having and I have tried several solutions. I think I might have finally gotten Linux installed but I'm not sure it done properly and I'd really like to see if I can get any Linux gurus here to help me out.

It's been a bit of a ride after the last few days (I've had work and I work 10 hour shifts 7 days in a row) so I have not had a lot of time to research into this issue greatly. I did happen to however, learn about a program called RUFUS. After looking at it for a while I downloaded it and created my bootable USB stick with EOS (Elementary OS) and created the image with my ISO. After doing that I saw I could either create the bootable USB stick as a ISO or a DD image. I did the ISO first because it was recommended and things were still not working so I ended up trying the DD Image. I played around with Ubuntu Gnome again both editions 14.04 and 15.04 and they still would not work. I tried enabling IOMMU and this would just cause a crazy amount of errors and then lock up at a terminal type interface so finally fed up I went back to EOS. I enabled IOMMU one last time created the image with DD instead of ISO and it finally worked! The problem was there were still a bunch of errors this time but I could connect to the internet! So I proceeded to finallay install EOS and get all my updates and then I restarted and from what I can tell things are finally working as they should.

My question is, will there be any way for me to verify everything is working and installed correctly? Is there maybe someone who would be wiling to take the time to help me run through and do a proper install to make sure things are working.

Also. I would like to dual-boot but I'm not sure the best way to go about doing that is. Should I first wipe out everything I have and then install Linux or should I install Windows first and then install Linux?

I appreciate any and all the help I can get here I know I have written an incredibly long wall of text and I'm sure I'm missing a ton of information. I'm about to head out to work so I wanted to get this down as quickly as I could. I will be checking this as often as I can while I"m at work.

P.S. I don't know how weird this is to add but if it would make things easier when I am at home if someone would need me to use Skype or another chat program to make things easier I am wiling to also do that.

Here are some pictures I took with my phone of some of the errors I saw.

As for the first picture of errors: you have/had this partition (/dev/sdb1) used under windows and it suffered from an so called unlcean shutdown.

As soon as you have a running live CD that command will fix that without the need to start and stop windows:

sudo ntfsfix /dev/sdb1

Are those errors when you try to bootup from CD? or when you try to boot the installed linux?

Try to use a normal bootable CDrom, maybe RUFUS messed something up

All of the errors you see there are from a USB with Linux I have tried booting it in USB 3.0 port and a 2.0 port. I'm not at home right now I will not be home for another 3 hours. I did manage to install Elemntary OS and I can boot into it but it was the only distribution I could boot into from a live USB that would still let me use my mouse and keyboard.

The USB3.0 and 3.1 controllers on the new boards are so new... i also had trouble installing win7 cause of that.

So would it be better for me to format all my hard drives and then install Linux first and then Windows?

If you want to dualboot that is usually the best way. Otherwise I think installing from an internal CD-ROM (attached by SATA) will do the trick and than update the os to the newest available kernel and hope that it than will talk to your USB. If that does not work well have to hunt for fixes

I omly have an external USB optical drive. I have never really needed one up until now, just my luck I suppose hah😑

I faced the same issue.. luckily I still had one laying around. That's the problem one gets with extremely new hardware.
I mean I even needed a spare SSD to get the working drivers onto that Z170 machine XD

Alright I am finally home and ready to start reformatting all my stuff. Is there anything I should do before I get started? Also as a novice would it be a huge challenge to use Fedora or a derivative of Fedora such as Korora or would it be better to stick with an Ubuntu based Disto with KDE or GNOME?

Here are my system Specs
AMD FX 8350
8 gigs of RAM
MSI R9 390 8 gig edition
128 gig SSD
My mother board is in the spec title

Well to be honest... I lean towards debian and its forks... I am just to used to it. But I would say fedora is as beginner save as debian...

I would say use what allows to be installed XD

Hmm ... I have also this board and had also some issues with linux ...

The major thing for me was to enable iommu in the bios and then tell it Grub ... with iommu=soft ... usb 3.0 works. I have tried LinuxMint, Ubuntu and Arch so far ... works fine with the board.

How do I tell Grub to use iommu=soft?

Edit: Going to head to bed for a few hours. I will check back when I wake up.

Thats a bootoption. You will have to edit the grub.cfg an add that to the line of the kernel options

I had to modify the file /etc/default/grub ... and there on this line add it ...
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash iommu=soft"
you have to do a "update-grub" comand afterwards in the terminal
may with sudo I think ... don't know it anymore

now it works everything fine ... with the mobo ... I run windows in a vm if I need one.
Also installing my R9 380 with the linux amd 15.9 driver worked after the grub modify.

Edit: atm I run Ubuntu Gnome 15.4

1 Like

Would I be able to do that while booted in Windows?

Sadly not, as windows has no idea how to talk to Linux OS partitions, thus you cant access them.

To temporarily add a boot parameter to a kernel:

Start your system and wait for the GRUB menu to show (if you don't see a GRUB menu, press and hold the left Shift key right after starting the system).Now highlight the kernel you want to use, and press the e key. You should be able to see and edit the commands associated with the highlighted kernel.Go down to the line starting with linux and add your parameter foo=bar to its end.Now press Ctrl + x to boot.

To make this change permanent:

From a terminal (or after pressing Alt + F2) run:

gksudo gedit /etc/default/grub

and enter your password.Find the line starting with GRUB_CMDLINE_LINUX_DEFAULT and append foo=bar to its end. For example:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash foo=bar"

Save the file and close the editor.Finally, start a terminal and run:

sudo update-grub

to update GRUB's configuration file (you probably need to enter your password).

On the next reboot, the kernel should be started with the boot
parameter. To permanently remove it, simply remove the parameter from GRUB_CMDLINE_LINUX_DEFAULT and run sudo update-grub again.