Help: Installing Linux Mint on Acer Aspire 5560


I am trying to install Linux Mint 14 Nadia 64bit (i figured the age of the OS would help being an older system since I’ve not much luck with Mint 18 either) onto an Acer Aspire 5560 (BIOS version is 1.15). I am using the live ISO which was written to USB using Rufus, Fat32 and MBR Bios & UEFI.

  • Booting from USB on the acer shows the grub screen, then a black screen after selecting the “Linux Mint” option.
  • The same USB key in another laptop shows the “Automatic boot in 10 seconds” and continues to boot fast, no problems (expected behavior I imagine).
  • Booting from DVD on the acer shows “Automatic boot in 10 seconds” and then continues to boot (again, expected behavior I imagine) but very slow and never boots into live session just eventually leads to white screen (I think the DVD drive is crapping out, but I’ll poke at that some more, it may be the laptop with the issue)
  • Will also try SD card install if the DVD doesn’t work with some patience.

I have tried Ubuntu, Mint (14 and 18), Debian yielding same results.

I also have tried this without avail: within the USB method.

Has anybody experienced something similar or might have some input to ease this installation? (I may eventually install using another PC then moving the hard drive over as a last resort, but ideally I’d love to figure this out and avoid that sort of thing).


Couple things.

1: Your laptop isn’t so old that a newer OS wont work on it. In fact you will probably have better luck with a newer distro.

2: I believe that if you use a GUID partition map (instead of MBR) that you will probably have better luck. I am not 100% sure on this one though.

3: It sounds like you have an issue with video display and not the distro itself. This sounds like a job for the good old nomodeset command.

When you get to grub press the tab button and type nomodeset and press enter.

Look at this page here for a visual representation of what you are supposed to do. Once you get the laptop booted up and install the OS, you can install and configure your drivers so that you wont have to do this again.

1 Like

I agree. I’ve had issues being able to UEFI boot from Windows 7 installer USBs when choosing “MBR for BIOS UEFI CSM” option.

Though with that being said, I personally haven’t seen Linux distributions not being able to have UEFI booting from MBR USBs, I’ve only seen that issue for Windows.

If it’s just a black courser on the screen after the grub menu try a different usb stick. Could try for an EFI format instead of MBR on GPT.

How would/could that be done though? Isn’t that a partition name, not a format?

I’m using that word loosely. I just mean try using efi instead of mbr.

Thanks for everyone’s responses!

I just tried a GPT partition table, and am using Mint 18.3 this time, but it appears to be the same issue as far as I can tell.

There is no ‘tab’ key command in grub that I can see (mint perhaps doesn’t have the proper version? maybe it’s rufus that needs to be updated (using 2.9)? or the ISO specifically I’m using from mint not proper(

Here is grub screen shot:

And i put ‘nomodeset’ after “splash” (not sure if it’s in the right spot):

and pressed ctrl+x and it black screened like it has been doing :confused:

Will try burning a DVD / SD card and see if that works
Thanks for the help :slight_smile:

Edit: oh and the computer DOES boot into debain which is currently on the hard drive, so the video card does seem to ‘work’ at least? Certainly could be an issue I suppose but it’s not like the card is complete toast?

For shits and giggles try loading up arch and see what happens. It may not have support for whatever graphics is running on that machine. I’d be amazed if that was a problem with linux in general, so you might just want to look at ubuntu mate (does mint run mate?) and the kernel may just be really old on the install disk.

Or you could try a minimal/cli installer (I assume mint has that?) and updating the kernel and graphics drivers afterward.

Happened on multiple distro installs with my machine for vega since they were all running a kernel way older than 4.15 for sure.

Mint does have a MATE option, I tried Nadia (mint 14) with MATE in my initial post, and it had the same problem. I have not yet tried 18.3 MATE however, which I can.

I can also give Arch a whirl, is the goal to see if it’ll boot into a non-desktop environment OS? Once I’m in Arch (provided it boots ok) I wouldn’t know where to go from there.

I’ll try these after the DVD/SD card tests with Mint 18.3 Cinnamon.


That usually yield the best results from what I’ve seen. (I mean I’m not a fan of it, but you get the idea. )

Arch seems to be the same thing, this is all via the USB:

  • black screen after selecting the first option (x86_x64 UEFI loader)
  • black screen after letting it timeout on it’s own (first option is highlighted, I guess it’s selecting that by default)
  • black screen after selecting the 4th option “EFI Default loader”

I couple things I’ve noticed:

  • Ctrl+alt+del does NOT reboot the machine once it has black screened, almost like it’s frozen? (Again, the hard drive boots into debian no problem so, it’s odd, almost like it’s a USB specific issue, will try to DVD route again I need to hook up a burner to my PC that’s why I did this first)
  • The USB key is NOT detected by the BIOS when I first turn the laptop on, 100% of the time. It isn’t until I ctrl+alt+del (reboot, without powering off - AFTER post and initial boot) that the BIOS then see’s the USB key and will boot from it.

It seems very odd.

Are you using USB 3 or USB 2?

1 Like

USB 3 key (Kingston 16GB)
USB 3 port on a windows PC when I wrote the image to the USB key
USB 2 port on the laptop

If you have a USB 2 stick try it. Had issues every week trying to install pfsense and proxmox, swapped over to my usb 2 sticks and they worked without issue.

18.3 Cinnamon DVD black screens, also the Arch via DVD also black screens.

I can’t try USB 2 as I have none (will have to borrow/buy and try), and I only have HC SD cards and I guess my reader doesn’t support HC because it won’t see the SD cards, so I’ll have to borrow/buy a non-hc SD card as well to test.

Either that or install on a HDD using another PC then swap the drive.

So I installed Mint onto the hard drive in another laptop, swapped it out and it worked magically (well I need to get this laptops drivers installed but this isn’t too big of a problem). If I get my hands on USB2 and non-HC SD card will let you know if it boots successfully with those options.

P.S. I had to prep the USB using MBR for BIOS & UEFI with rufus for the other laptop (Lenovo ThinkPad T400) as GPT wouldn’t boot the USB. Perhaps a BIOS setting but I didn’t poke too much at that :man_shrugging:

Thanks again all <3