Help! i have no os!

So I tried to root my Samsung Galaxy tab 10.1 and it went bad. So I said okay I will just wipe it and go to my old backup. But it isn't there!  The os that I was rooting to is also gone. So I need help! How can   another os on here?? 

Can I have the info on what you were trying to do and what your tablet is doing now? It's possible that you flashed the wrong rom that doesn't support your device which could cause some problems. 

I tried installing the ganborou I think that's how it is spelled. It says that it flashed and all that when I booted into the little twrp thing.  But when I went to boot it just just sat at at the green screen that that says the name of the mod. So I said well it must be broken. So  wiped it.  Thinking that I can just use the backup I took earlier.  But it was gone. So was the original mod zip. I now think that it was actually working and I was just not  enough. Now all I can do is boot into the twrp thing by holding volume down. 

At least I think that it is called twrp. Also it refused to shutdown it just started it's self back up which is really annoying so I unplugged it and let the battery die. 

Recent versions of TWRP have a power off/shutdown option. 

If you can boot into TWRP: download the latest Cyanogenmod 10.2 nightly, the correct Google apps, and be sure to do a wipe/factory reset beforehand.

If you are unable to boot into TWRP: Boot into Download mode. Using Heimdall, flash clockwork mod, then install the latest Cyanogenmod nightly for your tablet. 

Assuming that you have a 1st gen Note 10.1, follow these instructions if you can't get in into TWRP: