Return to Level1Techs.com

HELP! Gigabyte Trx40 and thread ripper 3960x build Wont boot up!

Hi guys

So I’ve finished by build and the pc starts up and all the lights work but I’m getting nothing through the GPU, I’ve tried a different gpu thinking it was that but it isn… am I missing something?

Faulty cable, bad CPU socket mounting, incorrectly installed RAM, PCI-E power cable unplugged. Try plugging in a POST code speaker.

Did you double check all power cables including cpu power cables?
If a system doesn´t post, then its power, cpu, memory or gpu related most of the times.
THose are the main components needed for a succesful post.

1 Like

Threadripper mounting tips:

  • Tighten in the order illustrated on the socket.

  • The orange Torx-bit screwdriver that comes with the CPU is a torque wrench. Tighten each screw until you feel a click, almost as though the wrench has slipped in your hand.

tried a different gpu… still nothing… removed all the ram apart from 1… there is power to gpu… I’m thinking faulty motherboard or cpu… I’ve ordered another off amazon and trying bench test tomorrow with the motherboard and the existing cpu

Does the cpu fan spin and other fans connected to the board when power on?

yes… its almost as if its working but nothing out the gpu… pump is plugged straight into the motherboard and it spins when switched on… I have taken everything out and put it on the bench for a bench test… I’m assuming just plugging in the gpu, the atx power into the motherboard, 2 pic power connectors into the gpu and the 8 pin connectors into the top of the board is all I need to make it work?

many thanks
Imgur
Imgur

Turned out it was a dodgy cpu… back to putting it together now… damn :slight_smile: