[Help] Freezing and Crashing on Game Launch on Fresh Windows Install

I’m new here and I tried to find a dedicated Help Desk section, so I apologize if this is in the wrong section fo the forum. BTW, found this site through a web search and it looks top notch!

I have had this machine for about 2-3 years with some upgrades between them and ended up with the configuration at the end of the post. The only things not mentioned is it’s connected to my Vizio 55" 4K through HDMI and I use an Xbox One controller with a cheap-o bluetooth adapter. I also have no overclocking.

Overall it’s been pretty stable only having issues with Forza Horizon 4(which was resolved through game updates), some random BSODs while encoding video files, and now with NFS Heat. I recently got Heat on Monday and started having a lot of issues. The first time I was able to get to the end of the intro race before the screen went black and I had to do a hard reboot. The next several launches of the game, my PC crashed on the loading screen. I’ve had a few “CRITICAL PROCESS DIED” BSODs. If I let it sit on the BSOD to repair, it doesn’t make progress and ends up rebooting to a “no boot drive detected” screen. If I shut it off and power it back up, it boots normally to windows. I decided to just re-install windows from fresh due to this and just to generally clean it up from strange programs I used once over the years.

After a fresh Windows install, sometimes the game crashes and I can relaunch it, only for it to freeze the PC. I still get the random BSOD CRITICAL PROCESS DIED message sometimes. I looked through my Event Viewer Logs and see “Error The IO operation at logical block address XXXXX for Disk XX failed due to a hardware error.”

I have reinstalled the game on my fresh install and now I got a message about the GPU being removed or crashed due to drivers being out of date, but they’re the most up to date? Maybe it’s my mobo?

I have checked all drivers, ran CHKDSK, ran WD’s SMART tool and everything came back as successful. I’ve read the Asrock AB350M Pro4 motherboards have random freezing issues, but not sure if that also applies to the base AB350M. What else could I be looking at?

Again, apologies if this is the wrong section!

  • AMD Ryzen 5 2600X 3.6 GHz 6-Core Processor
  • ASRock AB350M Micro ATX AM4 Motherboard
  • G.Skill Ripjaws V Series 16 GB (2 x 8 GB) DDR4-3000 Memory
  • Western Digital Black NVMe 250 GB M.2-2280 NVME Solid State Drive
  • EVGA GeForce GTX 1080 8 GB FTW Gaming ACX 3.0 Video Card
  • Thermaltake Versa H18 MicroATX Mini Tower Case
  • Corsair CXM 550 W 80+ Bronze Certified Semi-modular ATX Power Supply
  • Microsoft Windows 10 Education
  • Noctua NF-A20 PWM 86.46 CFM 200 mm Fan

I found the BSOD thread and checked my mini dumps folder and it was empty?


Do you have the exact model number for the memory? Might be compatibility between that and the board. Look it up here.

For a quick test you can just disable XMP and let the memory run at 2133 and 1.35V fixed.

I had the Pro4 for a couple days and it just wasn’t stable. It does look the same so it might be the same issue. But let’s rule out everything else first.

Thanks for the reply!

According to my email invoice: F4-3000C15D-16GVKB
Which does not seem to be on that list, but from what I recall I wouldn’t have bought them at the time due to it not being there. I also tended to use reddit where others seemed to sign off on them, but I guess that could be the issue? Strange that I haven’t had more widespread issues.

By disable XMP, I assume you mean create a profile rather than it being auto?

If so, I have done that and it has gotten to the actual game now! I will play it for a bit, then quit and try launching again. If this is indeed the issue, would you recommend buying new RAM or would it be okay to let run as-is?

Also, what lead you to RAM as the first step?

EDIT: I may have spoken too soon

EDIT 2: I have been able to consistently launch the game and play several times in a row now, but the sound quits(which may be a separate issue)

EDIT 3: on my 5th launch, it retained sound, going to play it for a bit and see if it crashes

Just experience. On Ryzen 1000 and to some degree 2000 it’s either C-States or RAM causing 90+% the issues.

That could be another thing btw: Disable C-States and whatever cool&quiet, power saver and efficiency features are turned on.

Oh, and check the ASRock website for the latest recommended BIOS.

Interesting, is there a general recommended 16Gb RAM kit for Ryzen?

Also, game just crashed PC at around 20 min playtime. Same error in Event Viewer, no BSOD.

I will look into those efficiency settings and double check my BIOS is up to date, I had just updated it not long ago.

EDIT: Disabled C-STATEs and BIOS was up to date. Game has crashed once, loaded up a second and third time without sound. Changed HDR mode in game to off rather than auto and got CRITICAL PROCESS DIED

Think I’ll look into a new RAM kit

EDIT 2: Figured HDR was confusing the HDMI signal and finally got it disabled without the game crashing only to load it up and have it crash the PC again. Think I’ll stop trying to play it until I get RAM and play some Halo since that works perfectly( as far as running lol)

If it crashes even on JEDEC settings, it is unlikely that a new set of RAM would help. … weird issue. :thinking:

How are temps?

Not sure what that stands for and web searching didn’t clear it up aside from memory settings. So I presume this means on 2133 settings. I’d have to agree since it’s still crashing pretty soon after launching. I was mostly moving on the new RAM due to finding CMK16GX4M2B3000C15 is on my QVL and at a local store. But I’ll hold off.

I don’t have temps handy, but the fans never kicked to full gear and I’ve never had it running hot even after hours of Forza or Halo. I can throw Core Temp on it tomorrow and enable logging if you’d like to see them though. I personally don’t think it’s temps because the PC set off all day today and crashed the first time I tried playing it today which was 1-2 min after boot.

I am curious, is this reproduce-able on another harddrive, do you have another hard drive sitting around? Any old internal hard drive will do.

I do have a 500gb laptop hard drive laying around I can throw windows on and try it out this evening

Here are things I tried this evening:

  • Ran in 1920x1080 - Started a couple times with no sound, crashed on third

  • Used Geforce experience to change settings to be optimized - game crashed almost immediately with sound and without sound

  • Tried it on a smaller monitor - No sound, PC crashed once and game crashed once. Got the below message on game crash on this monitor and it has happened a couple times on my 4k TV.

“DeviceRemoveREason: DXGI_ERROR_DEVICE_RESET (“The device failed due to a badly formed command. This is a run-time issue; The application should destroy and recreate the device.”). DirectX function 'g_dx11Renderer->getDevice()->CreateRenderTargetView(colorTexture->getTexture2d(), &dxDesc, &view->m_renderTargetViews[targetlt])” failed with DXGI_ERROR_DEVICE_REMOVED ("The video card had been physically removed from he system, or a diver upgrade for the video card has occurred. "). GPU: “NIVIDIA GeForce GTX 1080”, Driver: 44250. This error is usually caused by the graphics driver crashing; try installing the latest drivers.

  • Tried it on a 500Gb WD Laptop hard drive with fresh windows - Game crashed 3 times with the previous GPU error, ran 1 fine but without audio, and crashed the PC 1 time. I think this rules out the hard drive issue. I also forgot how slow traditional drives were lol

  • Tried it on new RAM that’s on my QVL and highly reviewed(Corsair Vengeance) and reset BIOS to default to enable XMP and C-states - BIOS didn’t recognize the 3000MHz, tried it on 2133 and 2933. Both times the game crashed, no error. One launch had sound, one didn’t. I bought new RAM because I was near Best Buy and figured I could just return it or sell my old RAM if it didn’t make a difference. Since it’s already in, I’ll probably just sell my old ones.

CPU Core Temps: Lowest was 32 and highest was 60(plugged into the 4k TV before Geforce install)

The other thing I’ll mention is that the GPU fans didn’t turn on while starting up the game, but did on boot, assuming it’s nothing because they only turn on when needed, but figured I’d mention.

I’m not sure where to go from here? Maybe I’m just not destined to play NFS Heat, but I doubt I’m the only one with a Ryzen 5 and 1080 combo with the game.

Quick edit: Was searching up the DX error codes and came across a ton of posts with suggestions that I will be trying tomorrow. Interestingly every post I see is about Battlefield, Apex, FIFA, or NFS Payback… all EA… I’ll report back tomorrow with what I tried and if it made a difference.

Have you checked a linux stick? Maybe it’s just windows being derp.

Last hardware thing I can think of is PSU. But other than that I’m leaning mobo.

I have not, but I don’t think the game runs in Linux. It’s the only game this is happening in so if the the things I found last night don’t work I’m chalking it up to EA and just putting this game in my “check out later” list. Thanks for all your help so far!

I don’t think it’ll be PSU as it’s been under more stress before, but if this starts happening in others games, I could look at borrowing another PSU from a coworker just to rule it out

Here’s what I’ve tried today:

  • checking Debug mode in the nVidia control panel - 1 game cash with error box, 1 PC crash
  • Change TdrLEvel in registry - 2 system freezes
  • Turn off Antialiasing in the Nvidia Control Panel settings - 1 game crash, 1 ran until game load then BSOD with CRITICAL PROCESS DIED
    *Turn auto-overclocking to maul in BIOS - 2 PC crashes with stuttering audio

I saw mention of manually set PCIe generation in BIOS, but I could not find a comparable option in mine.

I’m out of ideas except amother PSU(but PCpartpicker and. wattage calculator puts me around 399W on my 550W PSU) or a new Mobo. Not sure if it’s worth it for 1 game right now, but if the issue starts popping up in other games, then I’ll take a look into those. I see I have a 9 months window before the thread is closed, so I’ll be sure to update if anything progresses. Thank you so much for helping out!

I will be uninstalling NFS Heat and installing Jedi: Fallen Order along with Dirt Rally and GRID 2 from Steam. This is just to test if it’s only NFS Heat or if it’s EA or if there’s something larger. They only new game I have is MCC which is really two old games at this point. I don’t tend to buy games near release due to a huge backlog and issues on launch. I’ll report back in a few hours.

What BIOS version do you have btw?

It should stop at 5.00 or 5.40, anything later may cause potential issues.

This tells critical driver issue, is there a rogue device that hasn’t been named? like a USB/PCI-e wifi adapter?

This is what led me to ask if you could test on a separate HDD.

How old is your powersupply?

550w seems a little low here…

Does the computer exhibits the same issues with a different low-end graphics card?

1 Like

I do have a newer one than 5.4, so I’ll try and flash 5.00 and try. I believe this was updated before I I tried NFS

I do have a bluetooth dongle for my xbox controller, but that’s the only other device on my system. I can try without that and use a USB cable. I do not have any unknown devices in Device Manager

A separate HDD was tested and had the same issues.

My PSU is around 2 years old, got it with the system.

What buffer for the PSU should I have? I was under the impression that wattage calculators assume under Load and 150W buffer seemed enough?

I do not have another GPU, but may be able to borrow one

reinstalled NFS to test the below first two

  • Wired xbox controller with bluetooth adapter unplugged - no difference
  • BIOS flashed to 4.50 - Doesn’t even launch now
  • Star Wars - Ran perfectly on Epic settings
  • GRID 2 - Ran perfectly
  • Dirt Rally - Still downloading

chalking it up to this particular game and nothing wrong in my rig

You should be fine then.

I usually go with a 30% buffer, but that is my preference, 150w works just fine.

I don’t think swapping GPU will help, this may be just NFS being poorly coded.

That’s what I think the ultimate outcome of this is unfortunately, just glad Jedi is in Origin Premiere so I at least get my month’s money worth

Thanks again!

I’m reading a bit trough this topic.
If i understand it right, is NFS the only game you have,
this crash issues with?
Because if the crashes only occure with NFS.
Then it’s likely something with the game.

Are your gpu drivers up to date?