Help, Asus x570 Crosshair VIII Hero Q-Code D6 & Yellow DRAM light

Hi all.

Since April 3rd, i havent been able to get my pc to post into bios or display signal to my monitor. All fans go on full blast, showing LED indicators while also showing the AURA RGB lighting on the motherboard.

Had this build since around launch of ryzen 3000 with the following specs

  • Asus Crosshair VIII Hero (non WI-FI) x570 motherboard
  • AMD Ryzen 3900x
  • EVGA XC Ultra NVIDIA RTX 2080 Ti
  • Corsair RM850i power supply
  • G.SKILL TridentZ Series 32GB (4 x 8GB) 3600MHz
  • Noctua NHD-15s CPU Cooler
  • Samsung 970 plus m.2 NVME SSD

Troubleshooting methods i have tried.

  • Updated to the latest BIOS using usb flashdrive March 2020 build.
  • Q code from motherboard shows D6 error with yellow LED for DRAM error.
  • Tested 2080 Ti into another computer which is working fine.
  • Re-seated the graphics card
  • Booted with one memory module
  • Shuffled the memory modules
  • Discharged the caps by pressing and holding the start button
  • Swapped PSUs which is working

I have contacted ASUS and AMD support, both suggested replacing both CPU and motherboard… which seems ridiculous but i guess replacing cpu will make the most sense to be done first? What are the chances my motherbaord is broken?
Thanks in advance.

Chances are in general slim.

I have heard that there were issues on for example intels haswell and broadwell hedt chips dying from xmp settings with excessive VSA for example.

Maybe something similar has happened in your case.

I myself have two heavily degraded 2700x that won’t make it to the os on stock settings.
My Crosshair 6 hero does per default give them like 1.425V which I find excessive and which might explain the degradation.

Don’t worry, got them that way for cheap.
They still do their job.


The chances are slim that my motherboard is faulty? I had my profile also on XMP and more or less on default settings. Still waiting on a response from AMD support. Just seems odd for either my 3900x or my asus mobo to die… when i paid for the higher end hoping they were more robust and less prone to die as such. Hopefully it is just a software bug and not a hardware one? I will keep this thread updated as time goes on.

@plainNathanael - I’m not clear whether the failure may have occurred just after you updated the BIOS firmware? If so, that might point to a BIOS problem. Sounds like your troubleshooting has been pretty good. You might also consider:

  • Clear CMOS - restore default settings, reset memory clock to base freq, and hopefully clear any weird status.
  • Buy & swap in a less expensive CPU just for test, then keep it for backup & testing. Maybe a 2600? A bit pricey, but might be worth it to clarify the problem.

Good luck with the diagnosis & repair.

Firstly try clearing the bios. If that doesn’t work.
Try an older bios with flashback.

Hello Caped_Kibitzer, my problem happened before the BIOS firmware update i did to my system. At the moment i am going to try replacing my CPU with something else to determine if it is either my motherboard or CPU.

I have almost an identical build to you and my PC just Randomly died this morning after owning it for 3 months.

Was watching a tv show, so low load, and the system hard rebooted and got stuck at fan spin up.

Basically all my fans, including the 2080ti fans were spinning at full blast like they do during normal boot, though usually only for a second or two. All ram, gpu, motherboard, and case lights powered up.

Getting a 00 code on the motherboard with the DRAM light on amber. Tried everything I could find online short of using replacement parts as I only had an old GPU. Sadly nothing worked so I brought it into a shop.

I’m hoping it’s a faulty motherboard. I’ll buy one of those on the spot to replace. If it’s my 3950x I’ll probably warranty it due to the cost.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.