Return to Level1Techs.com

Headset Mic not Working - popOs 20.10

I am having a bit of Audio trouble with popOS 20.10
For some reason I can get audio through my headset (whether plugged into the front panel or using the rear input), but no matter what the microphone is not getting recognised.

Tech Specs:
CPU: Threadripper 3970x
Mother Board: Assus ROG Zenith II Extreme Alpha
GPU: Nvidia RTX A6000
Headset: Sennheiser Game Zero

I have tried everything in pavucontrol and alsamixer.
If I run hdajackretask it only displays the Nvidia sound card.

I get this when I look at the cards

cat /proc/asound/cards
0 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xe7080000 irq 157
1 [Audio ]: USB-Audio - USB Audio
Generic USB Audio at usb-0000:49:00.3-5, high speed
2 [Audio_1 ]: USB-Audio - USB Audio
Generic USB Audio at usb-0000:49:00.3-6, high speed

and the only codec in the system is this:
Codec: Nvidia GPU 9a HDMI/DP

Ironically if I change the preferences in Audacity to use:
USB Audio: #1 (hw:1,1)
or
USB Audio: #2 (hw:1,2)

It will actually pick up the mic input if it is plugged into the back or front ports respectively, but this just doesn’t seem to translate to anything that i can set in pavucontrol.
Is there a HD Audio driver for amd that needs to be installed some where?

Possibly add your user to pludgdev group.

Otherwise, maybe your device is not properly supported since it is showing up as a generic audio device. What is the make and model?