Return to Level1Techs.com

HDD stuck in read only mode on Ubuntu

Hello, to start off I am not too tech savvy and I have very little to none linux experience.
To sum um the problem is that the laptops HDD is stuck in read only mode, and what I want is to boot into OS and copy some files that are needed for work, but I can’t get past the tty1 screen.
So my sibling has a laptop with Ubuntu 16.04.5 and they used it for years. When they were transferring some files from USB onto a laptop the computer just rebooted in the middle of a transfer. When the laptop boots up it gives options to boot in Ubuntu or into recovery mode. When chosen to boot into OS it gets to something called tty1 screen, and it requires login and password. My sibling forgot the login and only remember the password so no luck there. So after hours on the internet, I manage to set some root login (Idk what it is but the login now is root and I set a new password for it). So now after I put that login and pw it logs in but nothing really happens after that. I have tried to put the ‘‘startx’’ command but it gives error ‘‘unable to connect to X server: connection refused’’ message. I went through a bunch of forum posts about solving this and trying to mount the drive back into read-write mode but I was unsuccessful. Except for 1 time, it actually booted to the desktop but there were no files or icons on the computer and all default folders were empty.
Honestly, after 7 hours of going through the internet and trying every line and solution, I came across I am lost for hope. I just want to go and copy a few work files of the laptop that my sibling rly needs. I force checked all filesystems, I tried unmounting/mounting partition, starting with startx and init5 command and bunch of other stuff with no result.
If someone knows how to help me and has the mental strength to explain to me step by step like I am a child on how to resolve my problem you will have my thanks.

Why is it booting to tty1 the graphical interface is on tty7.

Press ctrl + alt +F7 to get to tty7.

Also if a system is read only that should tell you right away there is an issue with the /etc/fstab file which tells the system how to mount a drive on boot.

Idk I can move to tty from 1-6 but I cant move onto tty7 and it boots in tty1 and sometimes in tty2 . And when I try booting with ‘‘starx’’ or ‘‘sudo init 5’’ it does like star booting in and show ubuntu logo bunt then comes back and says ‘‘job for graphical.target canceled.’’

What version of Ubuntu?

This startx and init commands will be useless on a modern Ubuntu because the default is Wayland which does not use xorg.

It’s also very weird that a fresh install would be so broken.

It would probably be easier to fire up a live install image, close the installer or just got ‘try’, and then mount your drive to copy data off. There is not a need to have to install the operating system first.

its Ubuntu 16.04.5, and it is not fresh install, the laptop has been in use for couple of years on this version.

Ok while that is older it does look to still be supported.

Does the install not allow you to test drive so you could just copy the data?

If what you care about is the data let’s focus on that first.

Yes the data is the priority if I could save or transfer data I don’t care about fixing the OS I would do an fresh install.
If there is the way for me to transfer data to external HDD i would like you to guide me through on how to do it step by step. If not I would like to fix the problem and be able to boot into the desktop (what currently isn’t possible i get stuck on those tty screens or I can open recovery panel).

I would also say go for a live USB/CD.

It is basically an a USB, which you can run to access file on the drive, and should work even if the drive is read only.

I would suggest you use up a thumb stick for the live copy of whatever Linux you like, and a USB HDD, if you have one, to save the files too.

1 Like

So I have to make a usb with boot drive linux? And if yes does it have to be same version or I can download newer ubuntu onto usb?

Any live version of any Linux should work

1 Like

you don’t Have to, but it will allow for a graphical desktop.

Any distribution will do, just whatever is most comfortable

Ok I have made usb boot drive how do I now create that graphical desktop so I can transfer files?

The boot drive should boot to a menu, with an option to “try before insatlling” or “run as live” or “live version”

Just try to not install over the drive you want to recover from…

If unsure, reply with a link to the website you made the USB from, and I can double check it’s the right edition, if that helps?

Thank you very much guys I managed to transfer the files to USB a save them, the only thing I could transfer were the photos but that’s ok they weren’t that important. Thank you very much Dynamic_Gravity and Trooper_Ish /S‽ for your help.

4 Likes