Having trouble with display outputs

I'm having trouble getting an output for a dedicated graphics card (Radeon HD 7970). I know that the card is capable in my current setup it works fine with windows 10 ,but I don't really want to use windows 10 because numa/multi-socket configs are kinda gimped on win 10.

My setup is as follows:
10x8Gb ddr3 1600Mhz ecc
Some c602 oem motherboard bios and other sources report it as: Inventec B800_1G P/N: 1395T2491604
Saphire Radeon HD 7970 (Have also tried with a GTX 480)
psu is a evga 750w 80+ gold
adata sp600 64gb for storage

I've tried to get a display for the dedicated card ,but for some reason it only wants to use the integrated display adapter (Some Aspeed graphics device: "1a03:2000" also reported as ast3200 in bios). This graphics device only has a single standard vga output ,and I need more than one monitor. I've attempted to find a setting in bios to change default graphics device or disable on board device ,but it seems that this is not an option on the motherboard(Possibly because of the ipmi's kvm over ip implementation). I've attempted multiple solutions found on google for Ubuntu 14.04, Ubuntu 16.04, and Debian 8.3 with both the GTX 480 and the HD 7970.

I think the closest solution I have found is use manually configured xorg.conf ,but last attempt at this seems to have broken display output altogether(xrandr prints "can't open display"). This last attempt was on debian 8.3. I'm going to give Ubuntu 12.04 a go ,but i'm doubtful that this will change much.

any advice?

So you are telling me that if you ONLY plug the gpu into the monitor, the system will still try to use the on board video?

Yes it seems so I think this has something to do with the ipmi's kvm implementation. Since it's a server board it seems that it outputs to the vga out on the motherboard even if it's not plugged in.

Is it possible to disable the on-board graphics device on startup?

Nvm I got the card to output on dvi and Ubuntu 12.04 ,but when I login the screen goes black and then goes back to the login screen.

I am gonna guess that you have to add radeon.modset=0

I would help you out more, but I am super busy right now. I will be free later tonight to help get this sorted out.

Hopefully @Eden or someone might be able to help you out for now.

radeon.modset=0? I just worked with xorg config until it started working ,but it seems that I broke it another way this time boots up with "running low graphics mode" prompt so at least that's something. I'll look into "radeon.modset=0" i'm assuming that's a startup variable.


I think what you are going to have to end up doing is installing the AMD catalyst drivers.

So you need to disable the opensource drivers long enough for you to install the proprietary ones.

I've already got the fglrx drivers installed just not able to get to desktop.

Managed to get it working so the steps I used are as follows:
1. install ubuntu 14.04
2. install fglrx drivers
3. aticonfig --initial
4. sudo chown -R $USER:$USER $HOME