Having trouble installing OS Debian based OSs on R710

EDIT:I just successfully installed Fedora Server 36 and it booted. I guess the question is why does that work but not any of the Debian based distros.
I bought a Dell PowerEdge R710 and wanted to install Proxmox 7.1 so I can use VM easily, but I keep getting an error it is fine up until that point. I tried Ubuntu Server 22.04 but it kept seeding snapd seemingly forever and then I installed Debian 11 which was fine until I tried to boot and it did not work just a flashing _.
I originally got it with Fedora 36 and the only meaningful change I have made is updating all the firmware for BIOS, iDRAC, etc. None of that fix it.
Also I am only using the iDRAC becuase the VGA cuts out after grub is a bit into it.

Are you booting via legacy or UEFI?

Legacy, but I tried UEFI on Proxmox and it did not work.

does the installer always fail in the same place?

as a test to rule out some hardware, plug in a additional blank USB drive and do the installer again, selecting the additional USB drive as the installer location. if that works and boots correctly, the issue is with your HD and or HBA config.

also, just as a double check, UEFI and virtualization are configured correctly right?

What config would I do for UEFI and virtualization other then enable and select the correct boot device?
Also should I have mentioned I am running 2 500GB in RAID1 for boot and 4 2Tb drives in RAID5

Also I just successfully installed Fedora 36. I guess the question is why does that work but not any of the Debian based distros.

in bios they are called Virtualization Technology, and Vt-d. (SR-iOV on the dell r710)

i would run the installer to a added USB disk as a test. this will eliminate a lot of variables.

That would boot from motherboard firmware, and the OS is booting (or trying to) from PERC 6/i BIOS.

Try installing and running on integrated SATA controller if there is one. Booting off the RAID card needs a functional BIOS on it, and PERC 6/i (LSI 1078) may be a bit wonky, and old, and only work with up to 2TB drives, and have trouble booting in UEFI mode. Check if it has a battery and what condition is it in.

I’d start there.

under the battery section of iDRAC it says it is “Good”.

Open it up (THE SERVER, NOT THE BATTERY if that wasn’t clear :slight_smile: ) and see if it’s funny looking, bloated or anything, it could be up to 15 years old. It should bi Li-Ion so take care.


the point is to boot WITHOUT the perc stuff at all, into an OS. this would help isolate where the boot issue is.

1 Like

Oooooooh, right. Basically I just repeated what you said, but more complicated…

1 Like

I have booted with the boot Virtual Device on Fedora 36. I did that today after trying Proxmox 7.1, Ubuntu Server 22.04 and Debian 11 which all failed. I would like to use sometime to make running vms easier.

no worries, i’ve become a lazy trouble shooter as i’ve drank more aged.

and did it do the same thing or something different?

1 Like

It when perfectly fine.

In order of attempts
Proxmox did not install the kernal successfully.
Ubuntu seeded snapd forever (14 mins).
Debain did not boot after installation. (this is what you both seemed to be trying to sort.)

I’d still try and install Debian based OS without RAID controller just to rule it out.

I tried to install proxmox to the other flash drive and it failed at the installation of the kernal again.
I will now try Debian.

I tried Debian and it did the same thing as last time.

In retrospect, maybe we should have checked the supported OS page first.
None of those are Debian based, or am I wrong?

None of them are Debian Based.
I have checked it before but thought it might have not been 100% set in stone what can be ran on the system, as long as it is x86 64 bit it should run.
But as a serious question, how important is it?
So are you saying RHEL, Windows, ESXi, Sun Solaris, and Citrix are the only OSs (or OSs derivatived from them) I can run?

At this point I’m not really sure. I would probably start disabling any devices I can and see if compatibility issues stem from any of those. Or try with Debian image containing non-free firmware.