Having some issues when I upgraded to a RX 6800 on Pop OS 20.10

So, I recently upgraded to a 6800 from a Vega 56 on a B550 r5 5600X system.
First I upgraded the kernel and all that to get it working, currently using Linux 5.10 and mesa from Oibaf PPA, all well and good, or so if thought…
Now I’m having many weird issues:
HDMI Audio is not working, first sound plays sort of fine, but then it gets exponentially laggier with every sound plays, like the latency just counts up all the time.
Everything feels laggy in X.org session(running gnome btw), looking at logs it looks like it constantly finds a new GPU, syslog gets filled with xrandr like lines.
In wayland it works sorta OK (with USB sound) but performance is not much better or in some cases worse than the vega 56 I had before (might be wayland? Seems a bit extreme)

Any ideas what to try next, tried resetting pulse audio config for HDMI sound, but not sure what to try that is not mentioned above.
In trial n horror mode right now

Solved it
It would probably have been an easy fix for anyone here given all the information, the riser on my node 202 was the culprit, set the port to PCIe gen3 and everything works like a charm now.
Queue Picard facefalm

1 Like