Return to Level1Techs.com

Having problems with virt-manager

I’m trying to experiment with GPU pass through and run a Windows VM but I can’t even create the VM. When I try and complete the setup I end up with an error.

I’m not sure what to do here as I’m new to VM’s on Linux. Also not sure if this is the right place for this post.

I am no expert myself but the message you get is basically a permission problem.

Let’s try to troubleshoot it: /dev/sr0 is the identifier normally used in Linux for the cdrom drive. Because we talk about a virtual machine here I guess it is about the virtual cdrom drive that gets emulated when you try to mount an *.iso file.

In case you try to install from an actual CD or DVD in a real drive please let me know.

Since I believe you tried to mount an iso file in the virtual cdrom drive to install the OS in your VM i believe you have a permission error in regards to the iso file. I Linux permissions are mostly categorized in read, write and execute. It says you have read only permissions. Normally even a virtual cdrom drive does not try to write to an iso but it might need execution rights.

Can you please let us see what the access right on your iso are with the console output of:
ls -al isofile

Edit: libvirt and by that also virt-manager only have access to the file if the group libvirt owns the files or if the user that owns the files is part of the libvirt group. When I setup libvirt for a user I always run
sudo usermod -aG libvirt user

1 Like

So I looked into it a bit more and apparently there’s issues with using a dvd for install. I used an ISO and it worked fine.

Good that you found a solution. I have indeed never tried to use a real DVD.