Having problems with my recent build

Hey guys,

For roughly two months I've been waiting for all the parts for my new build due to some delays, problems... but let's not remind me of that.

Here are the parts I ordered:

Gigabyte 990FX-UD7 (rev 3.0)

AMD 8350

Kingston HyperX Beast 2x8GB 2133MHz

Samsung 840 Series Pro 128GB

Asus AMD Radeon R9 290 DirectCU II

Corsair AX 760i

Last week once I got it all sorted out I used a DVI-to-VGA adapter to connect to my monitor (I know, who still uses a VGA monitor) and as soon as I turned the power supply on it started to run but no signal in the monitor I then turned off the PC by pressing the power button. Tried to turn it back on but nothing, same with the Motherboard power button. Also no code in the debug LED.

Afraid it might be the adapter I connected the computer to a TV via HDMI: still nothing.

This week I swapped the GPU for an old one that I know it works just to be sure it wasn't the GPU: same result, nothing.

Now it's time to come seek for your help, what do you think the problem may be? I'm assuming it's the Motherboard (therefore I'm posting under the Motherboards forum) or is it something so obvious?

Thanks for reading and for any further help.

My guess is the ram you have chosen is not supported on that motherboard. At least from what i read

this is what is known as a no post situation, its typically a problem with the ram, cpu, or motherboard, and is when the bios does not post or "start-up"


Since you are getting nothing on the debug led I would bet its motherboard or ram.




Double check all of your power connectors including the cpu 8 pin, if one of them is loose it can cause a no post.

Thanks for your replies.

I'll double check all the power connectors and see if it's the ram that is not compatible with the motherboard.

Was your monitor completely black when the computer was on? Like there was no "No signal" or anything like that.


This could sound like the black screen of death..


This is generally a MOBO problem.

The ram you have chosen is 2133 and the board only states up to 2000(oc). It should down clock by itself but this is not always the case.Even if it down clocks you will have to OC just to get 2000 out of it and maybe 2133 if it all plays nice.

Are you sure you have the ram in the correct slots?

The monitor was completely black, no signal at all.

I followed the motherboard manual to be sure I was installing the ram in the correct slots, so yes.

EDIT: And how do I know if the ram voltage will down clock itself?

To find which part is faulty you could try the following:

This can be slightly complicated.


1: First boot up without any memory sticks connected. (It should beep here, but if it doesn't follow the next step)

2: Then try boot up without the CPU. (if it doesn't beep here follow the next step)

3: Try to remove the CMOS for the night, and in the morning put it in and try again.


This is essentially just to trouble shoot where the problem lies, my guess is the MOBO.


Is your adapter in the DVI-I port? That's the only one that carries an analog signal.

http://www.asus.com/Graphics_Cards/R9290DC2OC4GD5/ is that your card? There are no DVI-I ports. Digital only.

If I remember correctly, R9 290 do not send analog signal to the monitor, using VGA afapter will not give you picture.

But, since you already tried with digital signal, i suspect that is motherboard. Anyway, you can't use VGA with that GPU (if first line is correct). Test different RAM with digital monitor, if that doesn't work, it is most likely motherboard, but also PSU shoudl be tested.

I went through steps 1 and 2 and it still doesn't beep or post... Hence it's the motherboard, right? Also, now when booting up the computer the fans no longer spin but I can hear a little buzz.

I'll try to remove the CMOS later today and will post the result once done.

I've had some very busy days but I finally removed the CMOS and booted the computer again after some hours but still no signal at the monitor... So it's now time to get a RMA for the motherboard.

Thank you for everyone's replies and help.

When my APU died I had the same problem: no post led and pressing the power button to turn it off did nothing. It turned out the APU was dead, my board was a Gigabyte as well

I'm sorry to hear that. Hope everything it ended fine for you.

Let's hope it's only the motherboard and not both. If after sending it to RMA they give the choice to get a refund instead I'm most certainly not going with a Gigabyte board again.

Everything went fine, I just wanted to post that just to warn you because of the fact I learned that a Gigabyte board won't post if the CPU is bad (when I sent my motherboard in they said that there was nothing wrong with it)

hopefully you cant test the board with another CPU cause it might be the CPU.

Thanks for the heads up as I didn't know about that.

I'll send the motherboard to RMA anyway as I don't have how to check if it's the CPU that isn't letting the motherboard to post.

Unfortunately I don't have any other AM3+ CPU to test the motherboard to see which one is faulty.

Thanks for your reply anyway.