Having issues with gpu-p with Tesla M40. PLEASE HELP

Hey guys, pretty new here but have been tinkering with computers for the better part of 20 years now.

I’ve been working on a project for some time now while reading different posts about gpu-p ever since it was implemented for consumer cards by nvidia with hyper-v, and I can’t seem to figure it out.

Long story short, what I’m trying to get done here is having Win10 pro running as the host with a gtx1070 (dedicated for the host) while partitioning a tesla m40 24gb to be split into 2 VMs for cloud gaming. I’m wanting to be able to play games while a couple of friends of mine can remote into the VMs via parsec, and not take a huge hit in performance when they decide they want to play. I’ve seen numerous people building a dedicated cloud gaming server and running gpu-p, and I’ve also seen many videos and posts of people gaming on tesla cards with output via igpu/apu. What I can’t find is anyone who has mixed these two ideas together.

The issue that I’m having seems to be at the driver level, as I can’t install a single driver that gets windows to see both devices in device manager. BUT, if I install the tesla drivers, and let windows install the 1070 driver, they both show up functional. Only issue, is when I try to switch the tesla card into wddm mode, and then restart, the tesla shows up with code 31 (driver error) in device manager.

Do I need to be hacking the driver to show support for both of these gpus?
Do I need to modify the bios on the 1070 to act as a quadro gpu?
Do I need to be modifying the registry for anything?
All 3 and/or other solutions?

Things I’ve tried so far:
Installing quadro drivers fails because no quadro present
Above mentioned installing tesla driver and letting windows install 1070 driver (fails with switching tesla to wddm mode)
Tried installing each driver individually, copying the folder from filerepository into folder on desktop for each card, then moving both nv_dispi.inf and nvdispwi.inf for tesla and 1070 into FR and restarting (tesla doesn’t show up at all in device manager. have only tried with 1070 driver installed first, may have to try installing tesla driver first and moving 1070 driver into FR and then rebooting.

Any and all help is appreciated.

Make sure you have UEFI mode in bios, UEFI mode windows, CSM disabled, above 4G decoding enabled, and if you have resizeable bar/SAM enabled if your board supports it

Clear all drivers, install Tesla driver, if you have enough bar space then it should install the drive for both cards

When you have 2 Nvidia cards from different generations, you have to install the driver from the oldest card. Nvidia is ending kepler/Maxwell driver support so, you’ll likely be stuck with an older driver for your 1070, but for now it should be fine

The 24GB Tesla is actually 32GB of bar space due to the way it reserves address space, it rounds up, your 1070 will take up 8Gb

40GB of bar space is kinda a lot

Jeff tryed Something similar maybe there is a hint.

He did it with a dual gpu Kepler card that has a gpu die that only itself and no other card has. I had commented on the video wondering about trying this with the m40, no responses yet hence why I’m wondering if I need to mod a card or something. Like turning the m40 into a Quadro m6000 24gb. Another thing to note, I never saw anywhere in his video showing that he switched the k80 into wddm mode. If stuck in Tcc mode, it’s going to work like trash as a graphics card (from everything I’ve read and seen).

So I do have all the features above, although unsure about resizable BAR as I didn’t know it was needed here. Currently running an x570 gigabyte aorus master with a 3950x and 64gb 3600 cl16 memory.

When installing the Tesla driver, the 1070 doesn’t show up until windows updates the device manager with the windows driver. I don’t see any big issue with rolling an older driver (as of yet). When I get home from work, I’ll post what shows up with Nvidia smi and what shows up as partitionable.

I have a titan Black and a tesla m40. I can use the tesla or the titan not both. If im using the tesla the titan Black is detected on device manager with an error or vice versa. Im probably going to get a low end radeon old card to replace the titan. No need to be wasting energy with a gpu thats only doing vídeo out.

hi, how do I know if my System supports addressable BAR space? this is my pc:

i’d like to use a m40 as a gpu (gaming and game development) and using the integrated graphics of the processor to get a video out

You’ll want to check out this thread
You’ll need Ryzen 5000 and x570 for resize bar
But any modern board with above 4G decoding should work
For further conversation

thanks, i’ll go in that thread