Return to Level1Techs.com

Haunted tech: different W10 version, same browser, different network speeds


#1

(I hope I nailed the category for this topic!)

Hi everyone! So, I’m facing this really weird issue lately that’s really making me scratch my head to the bones. I have a desktop PC with Windows 10 1607 installed and never did updates on it (I blocked them and forgot to do them, whatever). When doing speedtests with Chrome (it auto updates so it’s the latest at the time of posting) and everything’s in check, my connection works great and I get 930ish Mbit/s down like I should.
If I go to my laptop which has all the updates automagically done by Microsoft speeds are in the 700 Mbit/s. Both machines are wired directly into the modem/router so there’s no possibility it’s a bad wireless connection. Also I used to register the same internet speeds on my laptop but now they dropped. I tried closing everything, making sure it wasn’t updating in the background and so on. Nothing I can do to save it.
On another machine (Q6600, HP motherboard), same wired connection and same updates as my laptop, speeds dropped exactly 200Mbit/s (that machine did 500 at best).
This looks like a pattern to me. I can’t get to the bottom of this issue and nothing appears online. Has anyone experienced the same issues? I’m pretty sure that changing my OS to Linux would solve the issue.

P.S. my PC’s specs are on my profile


#2

It’s hard to say what the reason is, especially with Microsoft these days. Only have one small thing you could try, swap the cables and test it again. I had that happen the other day, suddenly speed dropped on one of my servers, after some tinkering, i swapped out the cable, and it went back to full speed.

I’ve been running Windows for over 20 years and have experienced similar to what you’re experiencing several times. I have investigated it more than once, but can’t remember I ever found a solution. I remember skipping a service pack on Windows NT or 2K because it reduced network throughput, think it was SP2 that gave problems, and everyone was happy when SP3 was released.

Not long after windows 10 was released, I decided that I’d had it, wiped my drives and installed Debian. I haven’t regretted that decision once, quite the opposite.


#3

My notebook and the desktop have cables running inside the walls so I can’t really swap them. I can try connecting the notebook to the plug where the desktop is and see if it makes any difference. Worth trying, thanks for the suggestion!

P.S. when I have more times on my hands I’m gonna go at least dual boot on my machines. Still haven’t decided how much space give each OS.


#4

Does the notebook using an hdd or ssd?


#5

Hehe, yeah, can see that. Would be a bit excessive to replace them. However, it is a very slim chance, just thought it’d be worth to try.

If you are going to setup dual boot and aren’t completely sure what you’re doing. Check out a few tutorials or guides beforehand. It can be a nightmare to deal with Windows EFI together with linux. I’ve had issues getting it to work properly if the linux distro didn’t support EFI boot.

If you’re not going to use you linux installation for “big” things, like video, gaming, Virtualization and the like, I’d do 20 gig for / and then 20-40 for /home. Personally I prefer to have /home on a separate drive, makes it real easy to reinstall and get things up and running fast. I only use linux and only for working, all big things I have on a file server. Below I’ve added my partition setup, so you can see an example of how I’ve done it.

Filesystem                               Size  Used Avail Use% Mounted on
/dev/sda2                                 46G  7.6G   36G  18% /
/dev/sdb2                                218G   85G  122G  42% /home
/dev/sda3                                173G  4.2G  160G   3% /opt
/dev/sda1                                509M  6.1M  503M   2% /boot/efi

#6

Another thing you could try is running a live session from a linux distro like Linux mint from a usb stick.
And then try what kind of download speeds you get on your notebook with wired connection.

It could also be a hardware bottleneck.
I mean your Q6600 system is probablly using some very old drives,
maybe even sata 1 / 2 or ide.
Those could cause a bottleneck if you have 1 Gbit up down internet speeds.


#7

Both notebook and desktop equipped with SSDs. The Q6600 is using a SATA II 3.5 HDD. The point with the last system is not that I’m not getting the full speed but the consistent drop of 200Mbit like I had with my notebook.
Are you sure a live distro would help me diagnose the issue? I thought that loading a generic driver would make no difference or even give me worse results.

@hem Thanks for all the informations! I’m not going in completly blind, I messed with Linux in the past but not on any of my work machines. On my desktop all my personal files ar already not on the SSD but on a separate HDD so the home will be on that drive. Regarding the notebook there’isnt much I can do about having home on another drive. I close here the OT, I don’t want to mix up things and mess up the thread. Thanks again!


#8

You dont have to install linux on your notebook.
You can just run a live session from a bootable usb stick.
If you create an installation usb stick with linux mint using rufus,
put it in an usb port and boot from the stick, you can boot live into the mint desktop.
Then you can test what speeds you get in firefox, and you can also install chrome.
This is all done in memory and wont mess with your systems ssd.


#9

Yeah, I didn’t mean to say that I have to install Linux to troubleshoot this issue. It was just in my plans to do and this issue is pushing me harder in that direction.
Sure, a live istance won’t mess with anything I have on my machines.


#10

Yup its probablly the best way to start troubleshooting.
If you get perfect speeds on the mint live session,
then you can say for sure that the problem is software or OS related rather.
But if you get the same reduced speeds in the mint live sesion.
Then it might hardware or cable related.


#11

I really hope it’s not the notebook’s nic giving up! I’m really liking this machine, does everything I need to do really well, I took good care of it.
I can test the cable that’s connected to my desktop through the integrated Intel driver, I might do that aswell.


#12

I wouldn’t be too worried about that.
Windows10 does allot of crap in the background by sending out telemetry and stuff.
So yeah that’s why an linux live session test could shine some lights on that.


#13

Like MisteryAngel says, Windows does a lot in the background, and since the drop is noticeable on more than one machine, I’d say the chance of it being a hardware problem is very slim, be that HDD/SSD or NIC. However, the idea with a Live Linux on a USB stick is a good idea, quick, straightforward and with minimal chance for something going wrong.

if it does turn out to be OS/driver related, perhaps it’s possible to roll back the driver in Windows or download a specific driver from NIC manufacturers website and work your way backwards in versions until you get the desired effect?

@MetalizeYourBrain in regards of the thread going off topic, that one’s on me, sorry for that.


#14

@MisteryAngel It’s really weird that the telemetry data transfer or other things like that have popped out as an issue just now and didn’t before. I think it’s just Microsoft pushing out this kind of updates that are more like a beta than anything else.

@hem I don’t think it’s a driver issue. I can’t really download anything from HP’s site since my machine it’s an Envy DV6 with an i7 3630QM, so it’s quite old and I doubt there are new drivers made for this machine. Also, to be honest, every time I messed with drivers to try and fix something it resulted in the machine (not this one, but an old P3 and the Q6600 on W7 years ago) going haywire so I think I’ll just make do for now and switch when I got some free time. No worries for the OT.


#15

With all the trouble there was with a recent update they released, I read they closed a department that has to do with testing of updates before they send them out. I’m referring to the update that introduced automatic backup to their cloud for files older than a month or something. Didn’t pay too much attention since I don’t run Windows, only read it to tell missus to hold back on updates for the time being.

@MetalizeYourBrain In regards to drivers, HP might not release new drivers for the specific model, but it is still possible that a driver was released for the network chip itself. Could be it’s just a realtek chip that’s used, and it would most likely be possible to find a driver for that specific chip and install that.


#16

Could it be meltdown+spectre patches?

I know one of the things they hit was networking.


#17

I’ve red that too. This layoff is hitting pretty hard Microsoft because Windows is getting shittier and shittier as time goes on. I thought they redeemed themselves after 8.1 (for me was a total mess!).
News aside I couldn’t find a driver on Realtek’s site for my nic and I don’t trust downloading drivers from shady websites not affiliated with Realtek in any way, shape or form.


#18

Why would I “pay the toll” of those security patches now? I thought they released them months and months ago. And, to be honest, I felt the effect of them on my notebook. Maybe they patched another vulnerability, I have to dig on this topic.


#19

At least on Linux, work is still ongoing on patches for speculative execution exploits.

I presume that MS is also still working on them also, but IDK.


#20

@MisteryAngel @hem @TheCakeIsNaOH Problem solved guys, it’s Windows being the issue. I booted Kubuntu 18.10 from a USB stick and got my full gigabit speed. Also today I registered 500Mbit, all time low. But the recent update fixed the notifications at least lol Thanks for all the help!