Guys I need help, Nvidia 960 gtx fans in Linux, driving me insane (Solved)

Hi guys, i need help with my build, i have a gtx 960 from MSI running in Linux Mint and as soon as i install the Nvidia drivers, fans get insanely loud. they are not quiet under the xserver, only bearable…

I tried all the Xorg.conf stuff with coolbits but the slider has no effect.
The Gpu is running at 37 degrees Cesius, which is not much above room temp…

I’m new to Linux so if anyone could help I would appreciate it.

AMD Ryzen 7 2700X

Linux 4.13.0-43-generic (x86_64)
Linux Mint 18.3 Sylvia - Cinnamon
NVIDIA Corporation
Renderer : GeForce GTX 960/PCIe/SSE2
Version : 4.6.0 NVIDIA 390.59

Thanks in advance…

Hey there - I got almost the same setup as you, difference being R7 1700X but I am running the same Linux Mint version and the same Nvidia drivers. My 4GB GTX960 from EVGA is running butter smooth and silent.

What I would check is the thermal settings in the Nvidia Settings app to check the temp on the GPU. Also, go into PowerMizer and check the PowerMizer settings. Mine is currently running auto which has the card set to ‘Adaptive’. If you have it stuck in ‘Prefer Maximum Performance’ then the card might be behaving according to that.

Hey dude, thanks for replying. No i tried all that in every possible combo… spent hours on this…
Whatever I do there is no effect, fans just spin at max speed…

Anything else I can check?

Thank you.

Still unsolved? Sorry I haven’t replied earlier. What is the kernel version you have? I know that sometimes nVidia drivers will misbehave if you have a kernel that is a bit odd etc. I got 4.11.0-14-generic running on my system.

I did a bit of googling and found some pages on how to control the fans, like this one:

https://setiathome.berkeley.edu/forum_thread.php?id=80538

But I have not tried those myself. YMMV.

I am running the GTX860M and have had a similar-sounding issue regardless of what distro. As soon as I did anything remotely intensive after installing the nvidia drivers the fan would go crazy. From that point, the fan strangely seemed to return to that state whether I was actually running anything or not (like gedit would literally set it off). It also occured in Windows, but only when doing heavier gaming - so not AS unusual…

It has been a while since researching it but, assuming you are not able to solve this issue with software to modify/control the fan speed, there are two things I remember reading about that can cause this soul-crushing noise to occure without the GPU actually being damaged:
1.) A piece of the film/plastic (like on new phone screens) that came on the GPU has slumped into the fan-blades path.
2.) I believe this is my problem: On certain gaming laptops, the GPU fan can begin to lightly scrape near the ventilation, producing a loud whizzing sound. Supposedly a slight battery-bulge from periods of overheating can be enough to cause this.

I realize this isn’t much of an answer, but perhaps it will help you narrow down the potential culprit(s). Slight physical obstruction seems to be relatively common and wouldn’t require you to replace the card if dealt with. If you think something like this could be the cause (if it sounds like the tips of the fan-blades are touching something) I would say the urgency scales with how badly they seem to be touching the potential obstruction. In other words, a physical obstruction may or may not result in blowing out the fan’s bearing, but should be resolved as soon as you can do so SAFELY.

I will say, however - that as of today (2018-08-01)(fresh install of ubuntu 18.10 and latest nvidia driver 390.77 ); I am not having the issue and it seems to be performing better than past experiences so… Fingers Crossed.

Check how fan control is set up in BIOS. If you haven’t created your own fan curves, it’s possible the existing curves spin the fans up dramatically once the temperature reaches X.

I always try to set fan speed as low, and as quiet, as possible for routine undemanding use and ramp up the curve as needed. As long as temps are acceptable, I’m happy to trade fewer decibels for a few degrees. Your mileage will vary per your usage.

Hey. I see some have already been pointing into a direction I have had to take with a few of my cards.
I had issues with fans on the gpu ramping up to 100%, and it was an “hardware issue”, as in fact, I had a cable that was in one of the fans, stopping operation and making the fan-controller on the GPU throw a frenzy .
My tips so far:

1 - re-check all clearance hardware wise.
2- check the fan-speed settings for the nvidia drivers - perhaps for some reason your uniqe settings puts the fans to 99/100% - try setting it by hand.

I don’t have access to my notes and the script I made to “automatically” change my fanspeeds since the machines are packed into boxes at the time… But I’ll give you the references I used.

https://devtalk.nvidia.com/default/topic/789888/set-fan-speed-without-an-x-server-solved-/

(yes - the arch-people really know how to write things down :wink: )

https://wiki.archlinux.org/index.php/NVIDIA/Tips_and_tricks

in short - to set it use:
nvidia-settings -a “[gpu:0]/GPUFanControlState=1” -a “[fan:0]/GPUCurrentFanSpeed=n”
where n = procentage of fanspeed.

Hope it helps.

I solved this by ripping the Gpu fans out and ziptieing a Noctua 120 fan, connected it to mobo… done! :slight_smile: