GTX 580 Bios Flash Issues

Hey guys, I've been trying to flash the bios on both of my GTX 580's, but I've run into a problem, and I was hoping you could help me out.

I've been following all of the instructions in this thread:

Everything seems to work alright, except for when I boot up the Windows 98 files and try to run NvFlash. I type in the command to flash to the new bios and hit enter, but every time I do this it tells me there is an error because the file is not a .rom file.

Normally this would make sense and be an easy fix, but the problem is that I did save the new bios as a .rom file, and NvFlash just refuses to read the file for whatever reason.

Any idea on how I could fix this?


Ok, so I've solved some things and I've also run into other problems.

First of all, True_Gamer's suggestion that I open the file in notepad and save it as a .rom file didn't work, so that wasn't the issue.

I did some looking around, and apparently the file name can't be more than 8 characters long, so I shortened the name. After that I started running NvFlash again, and it looked like it was going to work until I ran into another error. After running the command it told me this:

"Checking for matches between display adapters...

Adapter: GF 100B (10DE, ....)

Adapter: GF 100B (10DE, ....)

Overriding PCI subsystem ID mismatch

No matches found."

I did a little more looking around and I thought I found a fix, but it only led me to another error.

I typed in this command this time: "C:/nvflash.exe --index=0 -4 -5 -6 overvolt.rom"

So it went through it's normal thing again and asked me some questions, all of which I had to answer yes to in order to begin the flashing process. Then the flashing process started, but I ultimately got this error:

"Error: PCI Block corrupted"

I searched around a little more after that, but I can't seem to figure out what the problem is. Other people were saying that it was because people weren't using updated software, but everything I used for this is the latest version (GPU-Z, NiBitor, NvFlash, etc.) I really have no idea what is going on here, and I know this bios flash is working easily on other people's GTX 580s.

Anyone here know what the problem is?