GTX 1080Ti not detected in the first slot with RX470 in second slot by ASRock Z370 Professional Gaming i7

So I had this motherboard running with RX470 in the first slot and GTX 1080Ti in second for a while (for gaming purposes, since my primary system is Linux), but now I’m adding another GPU in the bottom PCIe x16 slot to have x8-x4-x4 config and I want to have GTX 1080Ti in the first slot for it to have x8 connectivity.

However, when I swapped the cards, motherboard behaves like there is nothing in the first slot. Removing RX470 from second slot makes GTX 1080Ti work again, but as soon as both of them are connected, the first one disappears from the system.
I’ve removed all components like SATA, M.2, other PCIe and even USB except these 2 cards and this seems to be a BIOS issue (I’m on latest version as of right now, 4.00).
I also did BIOS reset several times, same result.
I’ve even tried to downgrade PCIe speeds in BIOS just to try, nothing helps.

Already sent support request to AsRock, but since they are slow and useless most of the time, maybe someone have an idea what might be going wrong? Especially with L1 seemingly having good relationships with AsRock.

Replaced GTX 1080Ti with RTX 2080Ti, the same thing happens.

Looks like something wrong with RX470

What i would try to do in this case.

  • disconnect the system from wall power.
  • take out both gpu’s.
  • take out the bios battery on the board for a few seconds.
  • put the battery back, and put the 1080Ti in the top slot.
  • then fire up the system.

When taking out the bios battery for a few seconds when disconnected from wall power,
basically does a hard reset on the Uefi (bios).
This might solve your problem, but keep in mind that all setting changes previously made,
in the uefi are all gone then.
So you have to redo those, like date and time settings etc.

Sometimes a bios could go bonkers when changing gpu’s,
especially when you go from like AMD to Nvidia.

Is there an option in your BIOS to set the PCIe x16 slots from 1x16 to 2x8, or x8/x4/x4 explicitly?

I know how to clear BIOS and I did that a few times already while debugging the issue.
There is no option to configure PCIe lanes mode on any recent motherboard I had including this one.

Replaced RX470 with RX570 and it works with 3 GPUs just fine now.

It was either particular RX470 that was defective or some kind of incompatibility of that particular GPU and that particular motherboard+BIOS version.