Grub Unable to Boot OS

When I try to boot my server made up of almost all consumer hardware, it only gets as far as the Grub rescue CLI.

Leadup to issue:
The server was running fine and it had an uptime of multiple days. I had shutdown the system and unplugged it. Latter that day I transferred the hardware to a different case and removed the optical drive. When I powered on the system and let it boot, it went to the Grub rescue CLI and said “error: unknown filesystem.”

and the image shows some of what I have tried to get it to boot to no avail. I have also tried the Proxmox ISO, Boot-Repair, and Rescatux & SuperGrub2 Disk all via USB to try to repair grub to no avail (possibly due to me not knowing what to do and it doesn’t help that USB is kinda broken when live booting to the point where only 2 ports definitely work 100% of the time)

So if anyone has some idea of what might get it to boot into Proxmox I would be very grateful for the help.

CPU- AMD Fx-6300
MB- Gigabyte GA-970A-DS3P
RAM- 32 GB (4x 8 GB modules) non-ECC
Storage- 250 GB Samsung 860 Evo
NIC 1- Cisco VIC 1225
NIC 2- Dell H092P Pro Quad Port
GPU- PNY Quadro NVS 295 256 MB

OS- Proxmox VE 7.1

What is the drive type set to in the BIOS? i.e.: Legacy/IDE, ATA, AHCI, or RAID? Changing it to match the setting when the system was installed might fix your GRUB boot issue.

With a live CD, can you read the file systems on the disk?

1 Like

The drive type was never changed and it is AHCI. and with a live boot USB it can read at least some of the stuff but I’m not sure how much, due to me not really knowing how to check (aka if it is not auto mounted and having the data show up I’m kind of at a loss)

move the sata cable to the other port.

I have already tried that with every possible combination and unfortunately did not do anything

your OS install seems to be on an LVM partition. if the sata cable is in the same place as when you took that screen shot try this set of commands… we will call this option 1:

set root=(lvm/pve-root)
set prefix=(lvm/pve-root),grub

option 2: if that does not work (or it might be easier anyway) download the debian installer , boot to rescue mode, select the OS partition, once booted type
apt -install grub2

option 3: if you have proxmox backups of your VMs somewhere, reload and install the backups. honestly if you do have backups, this is probably the fastest fix.


Well for option 1 after the first 2 commands it seems like something is missing because it doesn’t work and throws errors when I try the 3rd command

Option 2: Did not work in the slightest

Option 3: when I try to install Proxmox fresh it throws an error saying “unable to initialize physical volume /dev/sda3” and that is even after i do a full disk wipe & set every bit to zero

this i have seen before, it is common on RAID controllers but can happen with SSDs. the installer didnt do the partition scheme correctly. during the proxmox install when it gets to disk set up shrink the size of the partitions by hand a few GB and then retry.

Do you mean decrease hdsize during the installation (example image of the page where the option is) or do something which I don’t know how to do after this point (which might require installing using Debug mode I think)

and thank you for the help

it should be fine to do the change there. That is a VM already though so that is not the PC you are having issues with, correct?

No this is me doing a fresh install of Proxmox on the bare hardware not as a vm

(and this is making me very glad that everything should be on my somewhat recently acquired nas)

the “8gb VBOX HARDDISK” is not a correct installation device, have you not selected the drive yet at least? or are you trying to install to a USB drive?

That is just an image I pulled off the internet, of the screen which I included to try and help eliminate confusing about my inquiry as to if adjusting hdsize is what you meant. my actual installation device is a 232 GB Samsung 860 Evo

And I used that image because the only difference on the actual system I’m installing Proxmox to is that hdsize defaults to “232.0” instead of “8.0” and Target Harddisk is “232GiB, Samsung SSD 860” instead of “8GB, VBOX HARDDISK”

1 Like

i would try a manual size of 220.

Think I figured out why the installer is having the issue. Aka when I wiped the drive I never reformatted it and the reason why I think that is the issue is because after I read the error message more closely It states:
“Warning: Partition table header claims that the size of partition table entries is 4292967295 bytes, but this program supports only 128-byte entries.
Adjusting accordingly, but partition table may be garbage.
Creating new GPT entries in memory.
GPT data structures destroyed! You may now partition the disk using fdisk or other utilities.”

1 Like

easiest way is to boot to GPARTED from a usb drive or something. it has a nice gui for that stuff. but yes, that ‘should’ make it better.

For what ever reason whenever I try using gdisk to add a new GPT partition table and MBR record, it is not saved and when I check it shows as no GPT or MBR present

So I have been trying to create a new GPT entry and write it to the disk but when I check to see if it has been written to the disk it has not been (have tried gdisk, fdisk, parted) so i can do
sudo gdisk /dev /sda Command: o Command: n Command: p (have the partition table show up) and then
Command: w and if i go into either gdisk or fdisk it will say something along the lines of no partition table found

there is a bootable gparted utility.

use it to create a new GPT record and do NOT create anything else on the disk. the proxmox installer can handle the other stuff.