Grub error no such device

I'm trying to install Arch alongside windows 10. what I've done so far:
fresh install of windows 10 on a 240GB SSD this created 4 partitions leaving 130GB marked as unallocated
then booted to an Arch Linux USB, and used cfdisk to make 2 more partitions #5 for swap and #6 for the main Arch stuff. Arch installed with no issues.
I initially had trouble installing grub but eventually got it to work by manually pointing it to the EFI file which is on partition #2 that windows made. I should mention I was following this tutorial
After installing grub I created the init, fstab, and cfg files like the video said, but after rebooting i was greeted with error: no such device: 32E498EB-15BE-44A3-A659-E1C0F8B48F2B
so far I have tried reinstalling grub, rebuilding all those files, booting to an Ubuntu cd and using gedit to compare the device ID in the fstab file and the grub.cfg file and they both read: 279FEDEL-AB75-4C3D-836C-F55F215D7940
So this makes me think that my earlier struggle with grub resulted in me partially installing another copy of it somewhere. do I just need to reformat and start over? both windows and arch are installed it would suck to cut it here when I'm so close.

other info that may be useful:
windows bootloader works fine (I'm posting from 10)
the Arch boot option shows up in the UEFI
secure boot is off, CSM/UEFI is enabled
system is an ASUS x99 deluxe with a 5930k and I'm trying to install on an intel 530 series SSD

any thoughts would be appreciated, I'm going to bed now ill try whatever in the morning.

Since it's a UEFI board, have you tried this?

That was probably not the best idea. Try to re-install the windows 10 Boot-loader with the windows installer disk then re-install arch using a separate EFI partition to the windows 10 one.

First find out where the error comes from:

$ grep -Ir 32E498EB /boot

beware: that you are looking in the /boot folder on your harddisk and not the /boot folder on your live usb.

Once you know which file refers to the wrong UUID, figure out which UUID is the right one:

$ ls -l /dev/disk/by-uuid/

open up the file with the error and replace 32E498... with the correct one :)