Greetings from another New User - Warning, LONG text ahead

Hi all. I am another new member here (though I’ve perused as a guest for a few months now). Nice to meet you!

The following is a BOOK … I know. I hope some of you might bear with me.

My current machine is a 15-year old custom-built job (Windsurfer PC … if you guys are still around, WOW, this thing LASTED!!!) using a Supermicro X6-DAL-TB2 Server motherboard and two Xeon Nocona processors. While I have never built a PC from the ground up before, I have replaced everything on this current rig except the processors and the motherboard … and I have removed the CPUs and coolers several times over the years for cleaning. So I am not TOTALLY a newbie.

Anyway, it is getting near impossible to source replacement parts for this machine these days. I am beginning to see new memory errors (already replaced the sticks twice over the years), and I really don’t know if it’ll survive another disection, thorough cleaning, and reassembly. So I decided to splurge and try to complete an item on my bucket list … build a PC from scratch.

I have been working on this project for several months … trying to ensure compatibility among all the parts, and trying to order the stuff so that all the sensitive parts are delivered as closely-together as possible, so that I could build and test, and possibly return defective parts within the 30-day window.

I have amassed a small fortune in these parts, most have already been delivered, and some assembly has already begun:

  1. Fractal Design Define 7 XL Case - now reconfigured as a server with drives in the back
  2. Gigabyte TRX40 AORUS Xtreme Motherboard
  3. AMD Ryzen Threadripper 3960x
  4. Noctua NH-U14S TR4-SP3 Cooler
  5. Extra Noctua NF-A15 HS-PWM fans to work as intake from the bottom and bottom front of the Case
  6. 128GB HyperX Fury 3200MHz RAM (4 x 32GB Sticks)
  7. EVGA Supernova 1300 G2 1300W Power Supply
  8. EVGA 08G-P4-3081-KR, GeForce RTX 2080 Super Black GPU
  9. 6 4TB WD Red PRO NAS HDDs
  10. 6 500GB Sabrent 500GB Rocket NVMe PCIe 4.0 SSDs, 4 for the AIC and 2 for M2M and M2Q Connectors
  11. 1 2TB Sabrent Rocket NVMe 4.0 Gen4 PCIe M.2 SSD for M2P Connector
  12. BenQ PD3220U 32 inch 4K Monitor
  13. EVGA PowerLink - (I dunno … looks like it might be neat - it was inexpensive)
  14. Pioneer BDR-2212 Internal 16x Blu-ray Writer Drive for top slot in Define 7 XL Case

So you might ask what do I need this PC for, and why, oh why, all that HDD space?? My current rig (yes, the 15 year old one) has 12 GB of space already. Much of it houses several years of photography work, and some of it is used for various programming projects I have undertaken over the years. I expect the photography efforts to continue (and maybe expand, given the new availability of HDD space), and I also expect to begin editing videos (something I have tried a bit in recent years, but do not have a machine that is really capable). In addition, this machine will also serve as Backup Point #2 for the other devices in the household.

So my main goals with this new rig are:

  1. Lots and lots of HDD space (one reason to build my own rather than buy a pre-built)
  2. I want the new rig to be as quiet as possible (something that has plagued me since day one with my old jalopy)
  3. I want this new machine to be powerful enough to easily handle video editing
  4. Though my budget is quite high, it is not unlimited, thus, no dual GPU’s, no 3990x, etc.

And now, the issue I just ran into…

Though I read, and studied, and watched videos of the process, I was not ready for the CPU installation to give me such problems.

First thing I noticed when I started the assembly was that there was no cover over the pins after I released the CPU holder on the motherboard. Okay, some reviews said that was missing. But I also noticed a slight “blemish” on the pins in the top-right quadrant of the socket. I was now WORRIED!!!

Second thing that happened was that after inserting the orange carrier into the rails, and closing it down, I could NOT get Screw #1 to catch. After about 15 minutes of trying, I googled that issue, and found out that it has been an issue for several years now (unfortunately, I can find no mention of it still happening with the sTRX4 Socket). I tried starting the other screws first (they worked okay), but doing so did not make screw #1 able to reach.

Putting the dummy protective plastic cover back into the slot, Screw #1 (and all of them) went in fine. But Screw #1 would not catch if the orange carrier was inserted. And yes, I was careful to ensure that the orange carrier was indeed within the guide rails on the sides. I was now getting a bit frantic.

Anyway, I finally, after applying an uncomfortable amount of pressure, managed to get the cover down and the screws secured until the wrench clicked.

I then installed the memory into the appropriate slots. I installed the Noctua cooler and plugged it into the MB header. I installed the GPU into slot #1, plugged in the 8 and 6 pin PSU cables, and attached an HDMI cable to a spare monitor that I use for a different rig. I plugged the PSU 24-pin and 12-volt connectors to the motherboard. I plugged the PSU into a 120V outlet and turned it on, and hit the Power switch on the MB.

The fans turned on, as did an orange LED between the CPU Socket and slot #1, and the digital readout said “00” (or as I found out after googling, “D0”, CPU initialization error).

Google searches told me to try using a single RAM stick, so I tried each of the four I had, separately … each in slot DDR4_A2. None of these efforts gave me a diffferent result than “D0”.

Google search results also told me to try a different PSU, but this guy is brand-new, and I had tested it upon delivery using one of those PSU Testing devices, and it had all checked out fine.

The only thing left was to reseat the CPU. Having had such an issue with that process, I was very anxious, but I managed to remove the cooler (not easy when the paste is making a suction … twisting and sliding and tugging made the whole process even more anxiety-prone), but I got it off, and cleaned all the thermal paste up with alcohol … trying ever so carefully not to touch the bottom of the CPU, but it was inevitable after a while, so I washed the cpu down with a CRC OD Contact Cleaner spray (is this okay?)

I then gingerly reinstalled the CPU into the socket. It went a bit easier the second time, and I was able to tighten down the TORX Screws to the single-click, and re-assemble everything to try again.

I got the same result.

So I got in touch with Amazon, and they agreed to let me exchange the motherboard. A replacement is coming. But I had to AGAIN disassemble the rig, putting more abuse on the CPU to detach the cooler, and then cleaning it all up one more time.

In retrospect, I am not sure if I should have also asked for a new CPU. Any advice here would be VERY much appreciated before I try this assembly again. The CPU is still within the 30-day return period, though I cannot say for sure if it is actually DOA, so it could be complicated.

I have been searching the Internet endlessly, looking for better solutions to the Screw #1 issues. I am amazed that this problem has not been addressed over the years. But it is what it is, I guess.

So, in closing … Again, nice to have joined you here on LevelOne. I would VERY MUCH like to hear any suggestions, comments and/or criticisms of my component selections, and any advice you might have regarding my installation issue.

Should I exchange the CPU? Do you think it could’ve been damaged by the pressure of the first installation attempt, or the twice - separation from the cooler and resultant cleaning I needed to do to it?

Thank you for reading this volume!
Warmest regards,

CPU’s are amazingly tough. You pretty much have to break something off of them to make them dysfunctional. Motherboards can require bending force to install things, which you can often see on old motherboards as they are usually bowed somewhere after years of heavy cards weighing them down or heatsinks clamping them out of shape. Just pushing RAM into slots anymore takes a solid push that bends the board. If the CPU was firmly in its socket then it wouldn’t get damaged outside of maliciously attacking it causing visible physical damage.

Alcohol isn’t half the solvent that water is, so I don’t bother with either. I slowly drag a dry cloth or paper towel across the surface to remove TIM (Thermal Interface Material). Never had one die, never cleaned the underside, got a box full of old CPU’s that work aside from a couple ancient ones with pins sheared off while moving. RIP Socket 370 550MHZ Pentium 3, you were a champ.

I’ve heard of the blemish thing, and replacing the board for peace of mind was probably the right call. I’ve never messed with TR, so no clue about the mounting system. Maybe someone else can give advice. Good luck with the new board!

Thank you so much, KleerKut. I had been thinking about the same. which was why I didn’t even try to return the 3960x. And though very different tech, I had used that same spray on my old Xeons many times before, and it never gave me a problem.

Your reply gave me a bit of peace-of-mind, which had been evaporating since my first attempt at installing that cpu. Thank you SO MUCH!

The spray is fine, I use it on cars all of the time. It won’t harm anything, but when it comes to the CPU or motherboard being an issue I always bet against the motherboard.

Kinda OT, but Alcohol is a solvent for different kinds of things than water is.

Have you ever tried to get Sharpe off of something? Water does nothing, alcohol takes it right off. Alcohol also is a better solvent for many oil and grease type products, and it generally works well on thermal paste.

Also, it evaporates more quickly then water does, and makes it easier to make sure the item is dry before using it.

This generally won’t hurt anything, but cleaning with a solvent would give better thermal performance in most cases. Although this would only matter if the system is really temperature-dependent, ie many laptops, some overclocking, etc, so even a degree or two might make a difference.

I’ve never had an issue with wiping a processor off and done it probably 100 times by now, but I’ll keep the alcohol tip in mind when I get sharpie on my processor pins.

Contact Cleaner is fine - totally safe as long as you allow to fully dry before reinstalling.

As far as the D0 code - how long did you allow the system to sit like that? It’s possible that with so much ram the system was just taking a bit longer than normal to do the memory training.

Though I have not done the procedure very often (three times for my Xeons over the years, and now twice on my new … still-to-be-successfully-booted 3960x), I have found that using a small piece of dry paper towel, wiping in from the edges of the still mounted CPU works well to keep the thermal gunk from getting into other parts of the machine.

Then I remove the CPU and use alcohol and a coffee filter to get off most of the rest, from both the cooler base and the CPU.

Then I take the CPU outside (fumes are deadly) and liberally spray a wash of contact cleaner over it, then allow it to evaporate and warm up (the spray makes it pretty cold).

I am SO hoping I have better luck with my next install attempt!

Thank you so much Kocytean - (as @regulareel suggested, I really probably should condense that first post, or maybe break it up into several distinct parts).

Yes, I DO wait until that Contact Cleaner evaporates. Using it also makes the chip very cold, so H2O condenses on it, so I find I need to allow it to become room temperature, too.

As for the “D0” code … hmmm … no I probably did not wait very long. I think I was really expecting the board to fail because of the missing protective cover and the visible blemish on the socket’s pins. So I was a bit frantic, and probably impatient.

But I DID remove all but one 32GB RAM Stick, and tested each of the four in succession. Admittedly, I did not wait very long. Once I saw that “D0” come up (it was immediately), I killed the power for fear that something else might go wrong.

In addition, I have now seen some posts that say I should’ve tried flashing a new BIOS. I had also never tried that, but I have since made a USB stick to do so with the new board if I have continuing issues with the installation of the CPU.

Thanks so much for the suggestion!!!

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.