GPU passthrough xcp-ng

Hello all, trying to passthrough a gtx970 and intel wifi card to a VM in xcp-ng.

I’m not seeing the nvidia gtx in the passthrough options:
image

When “whole GPU” is selected its PCI 11 (not sure what this value means)
image

Windows GUI shows:
image

LSPCI shows:

So the GPU is there… also the wifi card.

Interesting though that LSPCI shows the two physical NIC on the mobo as Realtek, and the wifi is intel but the xcp-ng windows GUI has it the other way around:
image

Also only one ethernet seems to pop up (NIC MAC address) and one for the Realtek, with the MACs only having one digit delta at the end, so not sure if a NIC is being confused with the wifi card.

Any help would be much appreciated, would love to give a VM access to the GPU for some object detection and wifi for some promiscuous mode logs.

You have to use the command line to pass through a GPU with XCP-NG. I have used the GPU passthrough setting in XenOrchestra, but that caused some funny behavior; I’m assuming that using XCP-NG Center will also cause some funny business? I tend to stick with the official documentation for this type of stuff (linked below).

Link: Compute and GPU | XCP-ng documentation

1 Like

I’m using XCP-ng Center and it’s nice to be able to do most of this through an actual interface without running 5 command line commands.

Right now, I’m just passing through the Intel built in GPU for Quicksync on two systems and it’s working.

1 Like