GPU Passthrough on Threadripper results in no screen output

Hi there!

As i could not write a direct message to @wendell i thought I’d post this to everyone.

I read a few guides about GPU pass through on (Arch) Linux and been working on this for the last two weeks. Basically i got a Win 10 VM running on EFI which is ready to receive a passthrough gpu, just that every time i try to add the GPU to the VM it boots and I see that it gets handed off to the VM, but the attached screen to the GPU just goes black, not receiving any signal. When i try again by shutting down the guest down, it apparently cannot reinitialize because virt-manager then tells me that it does not know what kind of pcie device it is.
When i use a virtual screen to see if the card appears on the windows device manager, it does not.

I have tried going by different guides multiple times and did all steps i could think of, as in checking immou groups, checking for an pure-efi image, installing virtio drivers, checking that the pass through gpu does not get occupied by the nivida driver and instead by virtio, to load all necessary modules to the kernel etc. etc.

I dont really know what i am doing wrong …

Watched some guides by @wendell as the ryzen guide and threadripper stream on gpu passthrough in which he mentioned that there is no “silver bullet” yet. So i wanted to ask him direclty about his experiences.

My guess by now is that i missed some kind of configuration or software to be installed, any idea what that could be?

Hardware: TR4 1950X, GTX 780 ti (pass through gpu), gt 710 for host | Arch Linux current

Edit: Huh, well what do you know. The workaround that Starlord has posted below allowed me to successfully pass through a 1080. This is on a Gigabyte x399 Gaming 7. It’s not perfect, but it does indicate some light at the end of the tunnel.

AFAIK ATM PCI passthrough with VFIO doesn’t work on Threadripper/x399. Especially with Nvidia cards.

I’m on a 1950x and a 1080 and it’s a no go for me too.

What motherboard do you have?

I believe our messiah and saviour gnif may be working on this issue, so hold tight. x399 is very new, things may work out for us.

Oh that is good to know…
Am using the Asrock Fatality.

I think @wendell also mentioned that xen works well with threadripper but i did not yet get to actually work on that :frowning:

This worked for me with an Asrock x399 taichi, 1950x, and 1080ti passed through

1 Like

Thanks, will have a look at that!

If you need any help making it work let me know. Been thinking about making a pkgbuild with the fix

1 Like

i dont think i am remotly able to actually do the fix myself.
i mean i know how to comment out code, but i’d need the sourcefiles, edit them and then compile, right?

and i already saw another forum post on how to use a script on the windows host to enable/disable the gpu as a device on os start / shutdown so that one is able to reboot properly.

Would that be enough?

And did you already fix that yourself?
Follow these instructions to download the source, compile etc then edit the file located at /drivers/vfio/pci/vfio_pci.c following the instructions of the reddit. And I just dont power off the vm honestly. Where’s the forum post for the startup/shutdown script?

1 Like

Here you go:

1 Like

Thanks. I’ll give this a shot and report back

Tell me how it went! Will have a look at your solution as soon as possible :slight_smile: