Good MOBO for a 9590

ok thanks for the help.

This is doom he just got the asus crosshair V and after playing games for around w hours it froze completely again. Would this be a cpu problem? His temps and core usuage are fluctating from 1Ghz to 5Ghz and drops to 12c up to 56c. What could be the problem.

cpu downclock can be caused by cool n quiet.
You can disable that feuture in the bios. under cpu options i suppose.

It is already disabled

bios updated?

I am looking into that and the bios version is 2201. And seems the latest is 2201 ? Went on asus website

Yep thats the newest bios.
You probably need to fiddle arround with the settings abit.
I suppose you running it at stock?

Yes stock i am searching google for a solution. I suppose pluging the extra 4 pin connector on the motherbaord is important although couldnt find a 4 pin from the ones that came with his PSU

yeah that definitely. that FX9590 cpu will pull a shit ton of power from that vrm

Thanks, but now the problem would be finding a pin to use lol

i dont know which psu you have ofc.
My 750W psu comes with an 8 pin cpu power connector,
and a additional 2x4pin cpu power connector.

just checked on mine and it also has a single 8 pin connector. His model is a corsair cx850M

Yep that psu only has one 8 pin eps powerconnector unfortunatly..
you might be able to get a molex to 4 pin adapter.
But i dont think that your problem lays there tbh.
Since there are also people who run FX9590ยดs on sabertooths.
single 8 pin should be fine.

its probably some bios setting.

it most likely just a matter of disabling a couple of powersaving feutures.
like C1 and C6 states.

yea, it's doing the exact same thing that the previous motherboard was doing. It has to be something spent a couple of hours troubleshooting and googling but haven't found a clue yet. He is making an account atm so he'll be posting here in a bit. Thanks for all the help so far

which value did you set for the cpu voltage?
try 1.47V.
and disable all further powersaving feutures.

that is the voltage it's currently at but haven't tried disabling all power saving features

You need to disable the C1E and C6 power states in the bios, to prevent it from freezing.
Check that.

  • cool n quiet - disable.
  • C1E - disable.
  • Core C6 state - disable.
  • HPC mode - disable.
  • SVM - you could also disable that, unless you like to do virtualization, then not.

i'm not at his house anymore so i'll tell him this but maybe it could be that he is overheating but i assume that it would just shut off instead of freeze.

sorry internet was down I'm here finally with my own account