Gnome-Shell not using Wayland? I'm confused

I just installed Wayland (Yay!) and the first thing I wanted to do was of course make sure that Wayland was actually being used instead of Xorg. In this case I'm using Gnome because I already had it installed and I know that it has Wayland support (can be choosen on Login through the DM). Now to check whether a program is using XWayland or native Wayland you can run looking glass (F2+lg) and choose that application. Now with most of the gnome applications (settings, rhythmbox, etc) and even right in the settings under graphics it says its running wayland (the string on looking glass is MetaWindowWayland). With the applications labelled as "gnome-shell" (there are 4 of them), it gives me the string for Xorg/XWayland (MetaWindowX11). Is this normal and if no, is there a fix?

I'd expect stuff like that, porting to Wayland is probably still WIP and Gnome has many components. Maybe something like Arch or Gentoo will have more recent packages.

Arch is actually what I'm using and thats the problem. To my knowledge there is no distro with more recent packages. I may just give KDE Plasma a try though

gnome-shell might be in compatibility more to allow other apps to run (just a guess).

Its looking like Fedora 25 will run GNOME with wayland as default. so your looking at GNOME 3.22 to be "first" main release to be using wayland as default.

If you're using nvidia proprietary driver, that could be an issue because as far as I know, nvidia proprietary driver doesn't (fully) support Wayland yet. You're actually not the first one that has the same issue. I'll link a couple of things I found.

https://bbs.archlinux.org/viewtopic.php?id=211147
https://wiki.archlinux.org/index.php/GNOME#GNOME_applications_in_Wayland

No I'm using amdgpu on kernel 4.7 (no proprietary nvidia driver for me). I guess Ill just have to wait until gnome 3.22 to get full wayland support (though it already work rather well). Also if anyones interested you cant game with wayland. Ive only really tried out Borderlands 2 so far but in that game, looking around gives some... interesting results

I hope there will be a new generation of extremist window managers, fvwm, openbox etc for Wayland

1 Like

I saw a patch today updated some wayland files. I tried it out by switching to gnome-wayland at the login screen. The desktop loads but i'm getting a few major problems, Is this AMDGPU problems again.
- Can't rotate a monitor to portrait
- Video playback is totally corrupted in totem, mpv, gnome mpv

Im using Ubuntu Gnome 16.10, RX 480, AMDGPU kernel driver.

I have had some issues with amdgpu in general lately and its now at the point where kde wont start properly and sddm wont start at all. Not sure about gnome though but I always had issues with wayland and the semi proprietary amdgpu-pro driver. Ill probably try the new gnome wayland stuff on a fresh install of fedora 25