Gnome shell error message flooding log


I’m trying to find out the root cause of this issue but no luck so far. The following log is flooding the syslog, getting several gigabytes in size:

Sep 16 08:42:54 linux-workstation gnome-shell[4572]: [4601:4601:0916/] ContextResult::kFatalFailure: Failed to InitializeGrContext for SharedContextState
Sep 16 08:42:54 linux-workstation gnome-shell[4572]: [4601:4601:0916/] SharedImageStub: unable to create context
Sep 16 08:42:54 linux-workstation gnome-shell[4572]: [4601:4601:0916/] GpuChannel: Failed to create SharedImageStub
Sep 16 08:42:54 linux-workstation gnome-shell[4572]: [4601:4601:0916/] OOP raster support disabled: GrContext creation failed.

Any idea how what is the cause of this issue and how to fix it?


Dist: PopOS 20.04
Kernel: 5.7.19

Not using Gnome nor PopOS, but you need to investigate “SharedImageStub”, which is probably related to NFS or Samba?

On 2nd thought, it’s more likely it has something to do with VM’s. Are you running this in a VM or do you run VM’s on this OS?

yeah, I have a Windows VM running with KMS and virtmanager

Are you still experiencing the logs filling rapidly? (From these messages)

I’m not sure that I’ll have a cause identified for the issue or a specific fix but maybe a workaround if you have not tried the below:

  1. Do you happen to be using the nvidia proprietary driver and wayland?

    I’m not sure if the latest gnome-shell on PopOS/Ubuntu has anything that might work with that at the moment (it may). I mention this partly because there have been some similar messages online regarding chrome/chromium and nvidia proprietary.

  2. By chance have you determined if it might be related to chrome/chromium web browser running?

    Possibly reboot or log out and then only use firefox for some time to see? (I’m not certain that it is related but am offering that as something to try out.) Some of those online discussions seemed to find that chromium was not having it’s types of problems (maybe not the same here) if using the intel driver instead of the nvidia gpu on systems that had both options. (Though the messages also are coming out of gnome-shell in rsyslog.)

Otherwise, if you are using Wayland then…

  • …you might try changing over to Xorg for some time to see if the messages stop and do not return or not. That might be a quick workaround if it helps. (example for Ubuntu, which may be similar; though it may be good to have PopOS community prepared earlier if you run into any issues.)

    Usually the graphical login manager screen has an option to choose your session type. With Gnome3’s gdm3 it is normally a “gear/setting” option thta shows after you select the user name but have not yet typed and pressed enter for your password.

    (gdm may still be using wayland but could later be configured to not do so if we find that it helps for the user session to be Xorg/X11 gnome instead of Wayland.)

I hesitate at the moment to recommend any updates of nvidia proprietary driver or changes that might not be as easy to gain back at least the current functionality, so I have not recommended that at he moment.

If there are PopOS forums it may be good to check with them as they are more likely to have other users already seeing problems similar to your and looking into them. (They will also be more familiar with the versions/issues on PopOS then I might be as I’m mostly a Fedora user; though some things are generally similar.)

It might be possible to tell rsyslog to filter out the messages, but if they come in through journald/systemd then there is unfortunately no normal way to filter it in the journal (because bad/noisy software should be fixed instead of ignoring it, or so the philosophy is upstream for systemd maintainers). (At least systemd has binary logs which might be slightly more compressed…)

Thanks for the help. I think it’s an issue with chrome and nvidia proprietary drivers. I don’t use wayland.
I filtered out the messages in syslog and no messages so far, thanks!