Return to Level1Techs.com

Giving up on the Xeon dream (The curse of Gigabyte Mobo Revisions 1.0 vs 1.1)

intel
#1

My Xeon journey started 2 years ago with my first E5-1660, which had a short because of improper air cooler handling.

Then, the 2nd Xeon managed to degrade because of using 8 sticks of RAM.

Then the 3rd Xeon was already degraded with a high VID at stock, and then the IMC was degraded due to running at 1866 too long

Then, the 4th Xeon was all good… but only for 11 months.

Finally, I said I would get a Ivy Bridge Xeon instead of a Sandy Bridge Xeon… TO NO AVAIL.

Turns out my motherboard, the Gigabyte X79S-UP5-WIFI is only electrically compatible with Ivy Bridge Xeons with Revision 1.1, not what I have, revision 1.0.

I’m defeated. I can’t do this anymore. In order to continue using my X79 system, I have to get a 4960X instead of a Xeon.

I spent 2 years of my life on this project and all I’ve gotten was criticism that I’m trying to polish a turd and that I should instead start with a new system.

They may just be right. My Xeon adventures have had no results of use whatsoever, and now I have to not choose a Xeon anymore.

The alternative if I wanted to keep the Xeon is to get a ASUS Sabertooth X79 or Rampage X79… both overinflated by the “Tech YES tax,” and I do see the 4960X is actually supported by my motherboard Revision 1.0.

Problem is, I’ve been beaten down to within an inch of throwing this system out the window. This is too much torture.

I hate myself.

0 Likes

Jack's Hardware: Rig Repair Log
#2

get a am4 board and cpu and call it a day

or intel if you need the ipc and have the money to burn

5 Likes

#3

AMD for tight budget builds all day.

Don’t hate yourself; do it for her heart

0 Likes

#4

in terms of single socket builds, i cannot recommend a xeon build at all. You should be using ryzen 8c cpu instead. Single ryzen 1700x beats dual e5-2670 in almost all cases (including performance of kvm’s.) Single con is price of ddr4, and limits of 64GB memory capacity of the socket (and 32GB for max performance vs capacity).

// I was owner of dual e5-2670 build.

1 Like

#5

All of the above, but only if you ignore that there is an unlocked 8-core Xeon for X79 and it keeps all the benefits of the X79 platform… A chip which I assume @FurryJackman is alluding to in their post when they say their board is not compatible.

@FurryJackman P9X79 series boards will support the 1680 V2 (and all other 16xx V2 chips) even if they aren’t listed. There’s a number of BIOS updates that add support but don’t list that it’s added in the release notes. I believe a few ASRock boards are also compatible despite not being listed. Check around, see if you can find somebody who will trade boards.

1 Like

#6

Best place would be on eBay, as usual, and there are a fair number of X79 ASRock boards there, not high-end ones but will do the job pretty well. Even Gigabyte tried to push out compatibility of Xeons on X79 chipsets out of their commitment.

0 Likes

#7

I see what you’re getting at. You’re like me. Hack your machines and make everything the best it can be. I like to do this with… Hobby machines though. My main machines are actually all laptops, 2 thinkpads, some apple powerpc machines, and an msi to soon take over as the main one.

As an opinion of the need for X79, trust me I get it. I like my favorite things too, and Iw as hell bent on an FX machine for years but… Here I am, on PowerPC and a 3rd gen intel core chip… WHERES MUH CISC BUT RISC BUT CISC CHIP?

Well, its being reserved when the newest TUF board from ASUS (Rev 3) is 150 USD or less. Then my 8370 machine will probably be my only serious desktop aside from a mac pro. But even then I won’t use it too often I don’t think.

Aaaaaand thats where I think you are friend. Trying to make it just work and for whatever reason it doesn’t want to. We all have these experiences. Fixing an arch install or changing oil. Something is just missing but you are pretty sure all the parts are there. But no real… Answer.

Point is, yes, a newer machine is going to do you well. Even if its X99 for whatever reason. IDK maybe you do a 1st gen Xeon Phi based thing, that’d be neat if you did tho. Point is, hardware replacement is needed. You could probably be on the same platform, something just is being dramatic like a teenager and not working. Hell, get a rev 1.1 board and chip setup and do an awesome X79 setup! Theres plenty of places to get parts, even new (see:scrapyard wars – think geek stores ) online or brick and mortar.

So there. Hope that helps. I’m stoned off my dick so I can sleep so if its rambling I’m sorry.

0 Likes

#8

To those saying “Get AM4”, you missed the point.

I was trying to be an ambassador like Bryan for Tech YES City on how these chips can do so much while coming in at a low price.

I had no clue about the Revision 1.0 vs 1.1 issue. Nobody online identified that as a legit issue cause I was the only one really trying.

Now we know. If you want a X79S-UP5-WIFI, get Revision 1.1.

X99 has a memory hole issue for Hackintosh and a weak IMC as well, hence why I’m not privvy to getting that.

Only option is the 4960X if I want to keep my board, because finding revision 1.1 is like finding a cat hair in a haystack.

1 Like

#9

I have that board as my current PC. Best to get the revision as it brings in some board adjustments.

And yes, it does uses a server-graded chipset, so do expect some extras like 8 SAS ports, but it’ll ensure that any Xeons will work with that board out of the box. Just make sure you have the latest BIOS so that you can run the later Xeons or Ivybridge-E.

0 Likes

#10

Wait, WHAT?

Are you using a V2 Xeon or are you not? If not, I would so appreciate a hardware swap. Would save me so much grief trying to track down a revision 1.1 or trying to get a 4960X as a consolation prize.

I am on the latest BIOSes, but only revision 1.1 supports Ivy Bridge-EP.

The board feature set wise is identical, except 1.1, the one you supposedly have, supports Xeon V2 CPUs, which I NEED. You won’t miss anything else if you’re just running a V1 Xeon, 3960X or 4960X.

0 Likes

#11

It looks like you have exhaustively proved that wrong.

Maybe instead be a pioneer with arrows in you back as to why this should not be done. Champion YouTube’s making a mess of good plans and get the attention that way.

Or you know get one one working system, never mention the hell you went through and lure others into the same trap you fell into and laugh derisively at them.

2 Likes

#12

What I don’t get is how rev 1 and 1.1 differ that makes the rev1 incompatible with ivy EP.
Socket pinout should not have changed, and then you say that the ivy i7 would work?
What the heck.

Rather sounds like a bios microcode thing instead of actually electrical differences.

What’s with that x99 memory hole? Couldn’t find anything on that with the 5 min I had.
Any pointers please.

And I get the feeling that you miss the point with your ram and IMC problems, since so many CPUs just giving up isn’t supposed to happen.

Another interesting thing you could try is to freeze your dead CPUs.
It might resurrect one.

My 1650v3 with dead IMC went from b5, b6 postcodes to b5, ram error.

I think you should get a blog and report about your daily tinkering.
EXCEPT, your regular “I hate myself” and “about to give up” stuff.

Do you have an idea what could cause a 0D postcode on an rampage iv formula?
With and without ram, pretty fast to 0D.

Edit:
And how can a bad mount of an air cooler cause a CPU to short out?
Can you please explain that to me?

0 Likes

#13

I had worse luck than Bryan, cause he happened to get stuff that just “worked” and I didn’t. Gigabyte never disclosed as a major issue that the revisions were so electrically different making V2 Xeons simply not work on Rev 1.0.

I thought it’s a microcode thing because the BIOSes are the same… Turns out it isn’t the same. 1.1 is different electrically.

0 Likes

#14

Yes, the 4960X will work but the Xeon V2 just boot loops.

The boot loop is INSTANT. Doesn’t even get to the early checks before the system fully shuts down and goes into a boot loop. That’s why I think it’s electrical, cause the BIOS is the SAME between Rev 1.0 and Rev 1.1. It’s not a microcode issue.

The X99 memory issue is more for Hackintosh. Maybe misphrased it as a memory hole:

Oh trust me, too much VCCSA and VTT can cause IMCs to just simply cause instant issues. I’ve been down that road many times with Sandy Bridge-EP degrading in weeks or months. On a side note, the Haswell-E processors have a VERY common IMC failure rate too, but Sandy Bridge-EP has a more serious rapid degradation issue.

And I had the mounting issue cause I was sick and forgot to screw in the nuts on the Dark Rock Pro 3 all the way, causing instant BSODs when I changed the orientation of the case.

0 Likes

#15

It very much sounds like he lucked out and did no research.

0 Likes

#16

Exactly. Getting ASUS motherboards, which are only compatible under certain revisions of the BIOS and not others?!?

Also, getting code to inject bootable NVMe into UEFI by chance!?!

This isn’t sarcasm, this is extreme luck on his part, without going through the hell I’ve gone through.

Without my main rig and Premiere, I can’t make a video refuting even more of his claims.

1 Like

#17

Thank you for the Link!

Oh trust me, too much VCCSA and VTT can cause IMCs to just simply cause …

Yea, sure! No doubt that IMCs don’t like too much voltage.
Again, why do you apply to much ? Do You really need to take the risk of a dead CPU ? But on the other hand, would you please provide info on what voltages you applied, and the respective degredations over time so that i don’t need to make the same mistake or rather know how long i can expect the cpu to stay alive? Please, and thanks!

And I had the mounting issue cause I was sick and forgot to screw in the nuts on the Dark Rock Pro 3 all the way, causing instant BSODs when I changed the orientation of the case.

Still sounds very odd. How does that actually cause a short inside the substrate or the chip itself ?
I mean, you have the ILM who should keep the cpu held in place and good contact with the pins.
There are plastic parts in the socket, keeping the cpu at the correct position and away from bottoming out and crushing the pins.

A cooler that isn’t tightened down should only stoop cooling correctly.
potentially causing a thermal shutdown.

Or the sudden flex on board while reorienting caused ram seating problems, BGA balls breaking, or what ever, but it’s unlikely that trew the cpu around in the socket, contacting pins it shouldn’t have and causing a permanent short inside the substrate or the silicon.

Of cause only with an ILM, if you didn’t use one, well then it gets plausible.
Except the question why you didn’t fricken use the ILM.

Now to the other CPU Problem:

The boot loop is INSTANT. Doesn’t even get to the early checks before the system fully shuts down and goes into a boot loop. That’s why I think it’s electrical, cause the BIOS is the SAME between Rev 1.0 and Rev 1.1. It’s not a microcode issue.

To repeat that:

The boot loop is INSTANT
Booting and looping and even POSTing sadly means something else for everyone.

But considering that THAT board does not have a postcode display, i assume that your cpu is dead.
Did you test it on a different board?
Do you have a debug card that can give you the postcodes?
Which does it reach, and at which does it loop ?

And looking at the product pages of the board, it makes absolutely no fricken sense that rev1 is so electrically different to 1.1 that V2 Xeons who adhere to the same pinout as V1, shouldn’t work in rev1.0

Makes absolutely no sense to me.

0 Likes

#18

It’s not just me, another person with the same board with a completely different V2 Xeon has the same symptom. It’s not a dead CPU. This person double checked on a different board and found the CPU wasn’t the issue.

Safe VCCSA is below 1.05V. Safe VTT is below 1.15V for Sandy Bridge-E. Going above 1.2V for VTT caused my CPU to degrade within 11 months. Safe Vcore is below 1.4V.

It could be a hidden microcode lock for specific flashed C606 chipset firmware specific to the revisions. If you want to dig deep into this board’s BIOS, go right ahead. If it gets the answer we need, this could expose something. It could also be Revision 1.1 has an updated C606 chipset chip.

If there’s nothing in the BIOS that doesn’t sound right to specific board/chipset revisions, it’s an electrical issue.

0 Likes

#19

Postcodes are the first indicator.
If it moves above 06, Hardware is good and it starts loading microcode and bios stuff.
If it loops there, BIOS.
If it loops before that, 00 or no post at all, dead cpu or maybe a problem with the VCORE voltage controller.
Maybe rev1 uses some older SVR spec and 1.1 was updated with a newer controller.
But i don’t know if Intel actually changed Voltage “SVR” standard between Sandy and Ivy. I doubt it a bit. Maybe they depricated support though, that could be.

EDIT its not “SVR” just VR. VR 12 and 12.5 on the IR2567b

0 Likes

#20

So, that would mean re-programming the VRM? Because the boot loop also happens on all other CPUs with the same behavior if the EPS12V is not connected.

0 Likes