Git, Gitlab, Gitlab-ci [Resolved]

Anyone with exp on setting up gitlab-ci? After setup my gitlab-ci pulls as my normal gitlab. i'm kinda lost at this point.

I see similar issues posted by others, but i find no resolutions.
(running on git 1.7.1 centos)

my gitlab.rb in /etc/gitlab/
has both

external_url ''
ci_external_url ''

gitlab_ci['gitlab_server'] = { 'url' => '', 'app_id' => "this is private", 'app_secret' => 'so is this'}

in git lab i have set application oauth also and ran reconfigure... i played around with it, and best i could get was 404 error which i don't get; proper setup bring me back to gitlab with different url...

I've set up both on the same machine before, but I don't really understand your problem.

  • First off, how did you install it (OmniBus package or manual)?
  • Are they on the same port/domain or separate?
  • What versions of Gitlab and GitLab CI?
  • Have you tried setting the callback URL from the GitLba Web UI (instead of manually in the config files)? See
  • Have you restarted the machine and both services at least once?

1) omnibus package
2) same port, different subdomain (domain is same)
3) newest i think - 7.9.1
4) Yes i did that, where is gitlab-ci config -- is it gitlab.rb?
5) Yes i already did few times.

I've only installed on Debian (not CentOS), but I would assume it's in /etc/gitlab-ci or/etc/gitlab_ci or /etc/gitlab/gitlab-ci. Something like that. It is a separate package, so it should not be in the same folder as the GitLab config one (or at least it isn't on Debian).

I don't have any folder like that, can you give me the name of the file (one thing is for sure name of the file that is.) I've read its completely integrated, could it be that it didn't install itself?

Should it have its folders or something? like in home? or someplace specific?

i only have gitlab-ci folders that i've found in /var/opt/gitlab

also inside of /var/opt/gitlab/gitlab-ci/etc/applications.yml i have proper settings

also i do have certificates (crt+key) attached for both sites.

I see a folder right there (in blue) named gitlab-ci. cd into it and look for a config folder or config files. On Debian, there is a folder called config with YML and RB files in it.

inside this folder

inside etc

I see you edited your post. Disregard my last one. You found the config file.

The top of that file should look for like this:

    url: ''
    app_id: XXXXXX
    app_secret: XXXXXX

The App ID and Secret are generated from the GitLab Web UI. The callback URL is also set there. Again, please see

at the end of the file i have

should i change it to look like in example?

Isn't that taking default 1st response i sent in ss earlier? as its defining vars in the upper place of file.

Yes, try that. Remove all of those lines (the ones here and the ones at the top of the file) and replace it with the one in the example link I gave. You don't need the "defaults" alias or the development or test modes at all anyways.

Didn't affect anything, i still have the same thing...

When I pull ci it takes me to

and takes me inside gitlab. [Not the gitlab-ci]

obviously i ran the reconfigure thingy. Should I try reboot again? I had not restarted it after i've set up to enable gitlab-ci module.

should it state here about gitlab-ci?

You don't need to reconfigure Nginx. You need to restart the GitLab CI service. I don't know how to restart services on CentOS, but on Debian it would be "sudo service gitlab-ci restart" If you don't know how, then just restart the computer.

Also, GitLab CI uses your GitLab application to login and verify for it. That is why it might be redirecting you. Try logging in and it should redirect you to GitLab CI and show you as logged in the top right corner.

1 Like

No, it won't say there.

It will be under Applications/Integrations though. Have you correctly added the application is and secret?

yeah like 100% sure, even baffled one of my programmers.
those commands work under centos too (6.x ones) but i have no such service.

"gitlab-ci: unrecognized service" i'll reboot it in 4min.

crap, its there.

Thanks... it must have required restart of its service...
guess i was panicking :| and didn't try to reboot.

No problem!

In the future I would recommend doing the manual install. The omnibus package always causes problems for me. Plus, by installing it manually, you can more easily see how it all works and diagnose problems.

Lastly, make sure that the traffic is actually going through Nginx. You don't want to use GitLab alone as the web server. I saw that your config files had the domain and port 443 in them. Nginx handles static files, SSL, and overall HTTP support much better and faster. The reconfigure command that you were using reconfigures Nginx's config files. To make sure that it is using Nginx, look at the HTTP headers on both a GitLab and GitLab CI page. You can do this with the Firefox or Chrome inspector. Just Google it. You should see "Server: nginx"

Have fun! I really like GitLab. It's not quite GitHub, but it's fast and very we'll developer for a free system.

well my problem was the the guide for manual setup on centos was not really there, and because of lack of higher version of git than 1.7.1 i though of going to centos7 which sucks balls.

(in centos7 they've changed basics and even ifconfig package is not being used anymore... and you have to call on sysctl and crap like that... can't go through /etc/init.d/ or even service)

Yeah its running on nginx, still i'm pretty new to it.
This is not setup for anything live, its so our programmers can decide if they want it or not.
(its not pci compliant)