Gigabyte X570 Aorus Elite won't boot from USB with linux image

Hello, i recently bought Gigabyte X570 Aorus Elite board and installed Windows 10(GPT), then i want to install ubuntu 18.04 but it can’t seem to boot to the usb drive containing the image. When i press F12 on the splash screen then choose to boot from the usb drive, it will return back to drive selection.
I used rufus(GPT) to create the bootable USB.
Can someone help me on this?

i’ve tried enabling IOMMU, disabling CSM and disabling secureboot

Well you could try Ubuntu 19.10 instead.
This comes with newer kernels that will work,
with your newer Ryzen platform out of the box.

1 Like

Not the issue. 18.04 works with ryzen 3xxx can confirm.

How did he flash the USB? Rufus gpt works but its better using MBR and gpt compat.

He should try using baleena etcher to write the image :slight_smile:

He should clear the secure boot keys and disable secure boot unless he wants to go through the pain like I do of signing his own kernels and nvidia drivers and grub to multiboot with it enabled.

I just found out that my flash drive was the issue lol. I tried with a new flash drive then it all works!

Thanks for your help guys

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.