Gigabyte Designare EX X399 Dead in the water, OR?

Good Day All,

I hope all is well.

Before I start, suggested topics pulled this thread with is pretty much EXACTLY what I am experiencing, except in a full system: Gigabyte x399 Designare EX no power

Now backstory, got these (2) motherboards 2nd hand, ended up using one & sold the other one. Found out they produced in March 2021 & carry warranty until 2024 HOWEVER, it was an auction sale which converts this warranty to only 7 days. So shit out of luck on that one.

I built the PC last week after struggling to find a cooler for my 1920x. & it shat the bed on Monday (08/11). This is more than likely due to something in my country called “loadshedding”, for those not from South Africa, loadshedding is this great phenomenon of having a really shitty government who does not maintain the country’s infrastructure & power supply (mostly because of greed & embezzlement over almost 2 decades) & cannot keep the country’s electrical grid online due to strain on the grid.

This results in power outages over 2-4 hour periods per day.

Now back to the topic, my system specs are as follows:
Gigabyte Designare EX X399 (no packaging or accessories must be stated)
TR 1920X (CM ML360 TR4 edition AIO)
Corsair Vengeance LPX 3600mhz 16gb
Galax HOF 2080ti
Superflower SF-1000F14MP platinum.

Everything ran perfectly for the entire week. On Monday I had this loadshedding from 10am-12:30pm - power restored at 12:00pm. I switched on my PC and had lunch whilst watching Wendell funny enough. I then went to shower and this is NB - I cannot remember if I shut down or if I put the PC to sleep NB.

I usually only ever use sleep in such scenarios of 10 minutes away from a PC, otherwise I always shut down fully. This is NB because of the power situation & behaviour of the mobo currently.

I come back from my shower, try turn on the PC & there is absolutely no life, no LED, no signs of any power delivery to the system. I make sure the power to the wall exist, it does. Try different adapters as one could have blown, nothing. I immediately suspect PSU or MOBO since there is no power delivery to the system as all, no boot, no post code, no board LED (only chipset logo LED on this board).

I start process of Elim on a spare mobo/cpu.
RAM
GPU
PSU all work & boot on the spare parts.

I moved PSU back onto TR mobo & same thing. The ONLY sing of life/power delivery to the board is when the first initial power button switch on the psu is flipped. That produces a white flash on the chipset LED (this always happens & I have used it as a power delivery verification step in the time I have had this PC to ensure I can boot the system). I cannot test if the CPU is dead as no extra motherboard.

I have tried clearing CMOS, jumping CMOS header. A suggestion to remove CMOS & AC power, then holding down clr_cmos button on the mobo to drain the remaining power out the system didn’t work.

At this point I’m stumped, to recap now - Either my motherboard was hit with a power surge & has killed the board not allowing it to boot, or & hence mentioning putting my PC to sleep, whilst I went to shower & put pc to sleep, the PC locked itself into a sleep state & is unable to boot out of the sleep state, I think this is plausible since the board receives power, but nothing can be done. No boot, no post code, nothing

The MOBO also has dual BIOS, so another option is the BIOS may have bricked itself & cannot do anything because of it. I have not yet tried the second BIOS. Next is the screw holes on the board, I have noticed some of the grounding material for the screws on some holes are flaking/disintegrating.

Another recap-
Possible scenario’s:

Dead/shorted Mobo [possibly CPU too]
Power surge
Locked sleep/hibernate state not allowing boot
Borked BIOS
Screw holes not having enough grounding material causing a short
Dead power management Mosfet on the board?

I must state the board has no physical burn/surge marks present.

I understand this is a long read, if you got here, very much appreciate it & TIA to any suggestions - I am stumped at this point. So are the people on my local Forum xD

I only know an answer to this one, someone mounted it with power tools… not a big of a deal most likely.

Surge protection kicked in (hopefully) and i would swap Bios and test, if still dead i would remove the CPU and check, maybe even try to update the Bios… outside of that i legit have no clue how to help you probe if something is physically broken, do you have a multimiter? because i think is the next step

I don’t understand half of what you mean here xD

But i have tested every combination of the system (i.e. remove cpu etc) I do have a multimeter & do think that is going to be the next step if I am to probe some mosfets etc.