Return to Level1Techs.com

Getting the same color settings on Linux as on Windows

So a few days ago I finally took the plunge and installed Pop_OS! on my main desktop (Nvidia graphics). So far I have been enjoying it a lot. But there’s this one thing for which I can’t find a solution.

Under Linux the colors of my display (Dell U2412M) look like shit. Everything is too blueish and whites are blown out compared to Windows.
I would like to have the same calibration under Linux as I have under Windows.

For some reason GNOME settings doesn’t want to load my Windows color profile (tried .icc and .icm files). I end up getting the message “missing information for whole screen correction”. The color profile doesn’t seem to affect my settings whatsoever.

I have been searching all day for a solution and have also tried using colormgr in the terminal, but all to no avail.

Would someone be willing to help me? I just want the same colors under Linux as on Windows. How can one accomplish this? What’s the solution or is there another way?

1 Like

Wow, I didn’t realise you can do this in the Gnome settings.

I only ever used the settings on the actual monitor, with buttons and my finger, like some simpleton caveman.

Now I see the menu item, I have 3 automatic profiles listed, none of which I can change.

Well, At least it kinda exists?

2 Likes

Is Pop! Using wayland or xorg? Might try to switch’em

I’ve been able to load my display color profile no problem on gnome’s display sertings. However I didn’t create it from Windows. Windows accepts the same file and both OS’s boot with my custom profile. Maybe your profile’s format is the problem?

1 Like

So gnome settings doesn’t like to load a profile that’s not installed via the command line for some reason.

Here’s the process I like to do. Using root permissions either in the command line (sudo) or GUI (gksudo) or better yet (filemanger command alias) admin:///path … Move your profiles to the following folder: usr/share/color/icc

Then gksudo open your gnome-color-manager. That often fixes it

Also welcome back bmsk

1 Like

So I followed all suggestions. There was indeed something wrong with the colour profile that originated from Windows. Linux wasn’t able to read it correctly. To fix this I created a new colour profile using my Mac (I know what a workaround).
Gnome settings was able to read this new icc profile without issues, but didn’t apply it.

Gnome-color-manager seems to not be installed on Pop and even after installing the package it can’t be opened (weird right?). So I ran the following colormanager commands as root:

colormgr get-devices-by-kind display (looking up device ID)

colormgr find-profile-by-filename /var/lib/colord/icc/<name of the icc file> (looking up profile ID)

Make the new profile default:

colormgr device-add-profile <display id> <profile id>
colormgr device-make-profile-default <display id> <profile id>

And for some weird reason that did the trick! After a reboot the right colour profile was installed persistently. I thought I would leave this here in case someone else ever needs it.

5 Likes

Thanks for the update!

[Welp, not fixed, a work around was found. Oh well!]

I don’t have a mac available. How can I create a icc file from a vendor based icm file for Windows?

weird thought, make a color profile in l i n u x

I tried to do that but gnome requires special calibration hardware to be connected?

Oh do you do photo work?

The reason I say this is that there is a settings menu for color space that you can go through. Its not like on windows at all.

Gnome doesn’t allow me to calibrate the screen.

If you go to settings > devices > display, you can set stuff like sRGB or Adobe 1994/8 color spaces was my point.