Return to Level1Techs.com

Getting the Epson Perfection V600 Photo Scanner Working on ElementaryOS Juno and Ubuntu 18.04

I recently bought an Epson Perfection V600 scanner to digitize some old family photo and found after downloading and installing the drivers from Epson’s website

http://download.ebz.epson.net/dsc/search/01/search/searchModule


and installing the driver and software installation deb files in order
1: iscan-data_1.36.0-1_all.deb (data folder)
2: iscan_2.30.2-2_amd64.deb (core folder)
3: iscan-plugin-gt-x820_2.2.0-1_amd64.deb (plugin folder)

The scanner would simply not be detected properly. sane-find-scanner would find the scanner but scanimage -Lwould not detect it and I would get the message

5rA4X

After some research, it turns out the problem seems to be related to missing symlinks to the epkowa (SEIKO EPSON) libraries in the /usr/lib/x86_64-linux-gnu/sane (or, more generically,/usr/lib/$(uname -m)-linux-gnu/sane) folder.

To correct this and get the scanner working do the following:
1.Create the symlinks

sudo ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/x86_64-linux-gnu/sane

  1. Added a 820-epson-libsane.rules file to /etc/udev/rules.d/

sudo nano /etc/udev/rules.d/820-epson-libsane.rules

3: Then add the following lines to the file and save:

SUBSYSTEM==“usb”, ENV{DEVTYPE}==“usb_device”, MODE==“0666”
SUBSYSTEM==“usb_device”, MODE==“0666”

ATTRS{manufacturer}==“EPSON”, DRIVERS==“usb”, SUBSYSTEMS==“usb”, ATTRS{idVendor}==“04b8”, ATTRS{idProduct}=="*", MODE=“0666”

ATTRS{idVendor}==“04b8”, ATTRS{idProduct}==“013a”, MODE=“0666”, GROUP=“scanner”, ENV{libsane_matched}=“yes”

4: Finally I unplugged / plugged the scanner back into a USB port and ran the scanimage in the terminal

sudo scanimage -L

Result should be:

device `epkowa:interpreter:007:017’ is a Epson Perfection V600 Photo flatbed scanner

The scanner should be detected once reconnected and powered on even before running scanimage -L

It seems this is a problem with Ubuntu 18.04. The scanner seems to be detected in other versions of Ubuntu
Hopefully this helps others

3 Likes

Have you tried VueScan?

https://www.hamrick.com/

2 Likes

Thanks for the contribution bro! This is very helpful.

1 Like

It’s a very awesome piece of software. I’ve used it for old unsupported film scanners and it worked great :smiley:

2 Likes

Thanks for the feedback, really glad the post is helpful

1 Like

will have a look at it. Need something that’s good for image correction, especially fixing things like sun fading of pictures

1 Like

Running Desktop: Gnome 3.28.4 Distro: Ubuntu 18.04.3 LTS

I installed the latest drivers, now from 8/19, and I was able to see the scanner before I followed your instructions using sudo sane-find-scanner or sudo scanimage -L but not without sudo

I followed your directions and got the same result.

My guess is that the scanner apps don’t run as sudo, so how do I get this thing working?

[email protected]:~$ sudo scanimage -L
device `epkowa:interpreter:003:007' is a Epson Perfection V600 Photo flatbed scanner


[email protected]:~$ scanimage -L
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Turns out that running sudo simple-scan from the command prompt works.

Glad you figured it out. Just seeing your post now.

I should have said, I use the XSane Image scanning program. It seems to open Simple Scan automatically when I run it. Because I am scanning multi-page docs or photos that require some editing, XSane seemed to be the best all round application for me. It is quite a bit featured and looks complicated but it’s surprisingly easy to use. Simple Scan is really just there to make sure the scanner is connected.