Getting the AMD RX 5500XT to run in linux

Hey there,

I got myself a new GPU and thought it would work under linux. So far I spent all day getting it to work and failed. Whenever I try to install the amdgpu driver I get the message WARNING: amdgpu dkms failed for running kernel. Apparently it’s not possible to install the amdgpu drivers on kernels that are newer than 4.15. Another option would be to use a kernel with a version 5.5. I looked up my error message, but none of the reports used the version I used (19.50-967956) of the AMD drivers. I hoped the reported issues were fixed.

I am very unsure how I should proceed. So far, I have been using kde neon, which comes with a 5.0.0 kernel as far as I can see. Would it make more sense to switch distro, update to an unstable kernel or maybe even downgrade the kernel version?

Any help, advice or pointer would be great.

Some resources I found:
The problem I ran into as well with my RX 5500 XT. Some solutions are mentioned.
Phoronix article (using 5.5 kernel)


I would suggest adding the tag ‘Linux Helpdesk’, so more people will be notified of your post.

I thought these should work out of the box without doing anything? Are these too new? Also bump.

Thanks, I added linux, helpdesk, amdgpu to the tags. “Linux Helpdesk” was not found as tag.

1 Like

I’ve had no problems running amdgpu on any kernel version. You also should not be using amdgpu-pro unless you REALLY need to. The open source amd driver is in mesa, and the rest in the kernel, so it should be in your kernel already. The only major reason anyone runs amdgpu-pro is for the opencl (not openGL). Maybe try to just use it and not install the pro drivers? Also, what distro?

EDIT: You’ll have to run 5.5 for that card. A downgrade is not possible to get support for a newer card. You either need to install 5.5, or just wait it out with a different card after I read the phoronix article. I would highly recommend against pulling an old kernel with pro drivers as those are generally horrible to deal with in my experience, and you will have less headache with 5.5 RC’s than the pro drivers.


Hi, thanks for your reply.
I’m trying to avoid the amdgpu-pro version, because I don’t see any advantages in it really. OpenCL is not something I really need.

I’m surprised that you didn’t run into any problems with your amdgpu driver and newer kernel versions.

I might send the card back and switch to one with better support. Waiting for the 5.5 kernel takes too long and I don’t really want to fight with all the additional problems that come with it.

Overall I am quite disappointed. I really don’t understand this support gap. Old kernel + amdgpu is supported, current kernel is not supported, future kernel without amdgpu is supported.

AMD cortrols the code in the closed source driver, so they can add things early in there. The open source driver is not controlled by them. The pro driver targets only LTS kernels, which is why it works on older kernels, though they contributed code to the open source one, after the 5.4 merge window was over due to timing of the release. It should be pretty easy, depending on your distro, to get a 5.5 kernel.

1 Like

What exact kernel version you guys managed to get amdgpu-pro compile and work?

For my AMD Radeon RX 5700XT I tried amdgpu-pro v19.50 installation on modern Ubuntu 18.04.3 kernel 5.3 as driver claims it’s supported but compilation failed with C++ errors. Tried the same on 5.0 and 5.5.2 kernels with same results (on 5.5.2 kernel it was different error though: fatal error: drm/drmP.h: No such file or directory - on 5.5 kernels drm has way different structure so you can’t even symlink it).

Currently I’m on kernel 5.5.3 with mesa 19.3 installed. clinfo prints a lot of satisfying information seeming it’s all cool, but with such tiny little line in-between:

fatal error: cannot open file '/usr/lib/clc/gfx1010-amdgcn-mesa-mesa3d.bc': No such file or directory

which causes kernels compilation to fail (with the same error).

Anyone having any luck getting navi10 GPU OpenCL working on Ubuntu any distro?

Are you… on kernel 4.15?

If so please update. Even the 5600XT has support now.

I’m on kernel 5.5.3! So far tried installing amdgpu/-pro on fresh installed Ubuntu 18.04.3 kernels 5.0, 5.3, 5.4, 5.5.2 and 5.5.3 - still no luck ;( - having slightly different compilation errors. Every installation attempt gets about 2 hours to do and funny how in last 2 days I’m trying to get amdgpu-pro drivers to install kernel 5.5.3 got released ^^ - also tried.

From kernel 5.5.0 on you don’t need to install the amdgpu driver. I don’t use the Pro driver because I don’t need the extras (opencl and such) and the increase in performance is not that much.

The problem I have is exactly with OpenCL support, getting this error from clinfo:

fatal error: cannot open file '/usr/lib/clc/gfx1010-amdgcn-mesa-mesa3d.bc': No such file or directory

and when I try to build programs which use OpenCL (including mine one) I get similar error :frowning:

Then install the opencl libs?

I have had no issues with fedora 31 and my 5700xt

@nx2l Have you managed to install amdgpu-pro drivers?
Anyway, I still couldn’t get amdgpu-pro to install but got OpenCL working:

  • Ubuntu 18.04.4 fresh install
  • update kernel to 5.4 (couldn’t do next step on kernel 5.5)
  • install Mesa 19.3 drivers from secret source (can’t include links to posts)
  • other libs (including OpenCL modules) can be installed normally

no, i dont need that.