Getting Linux working on the G14

So I got the Asus Zephyrus G14 recently. Generally very happy with it all things considered, but the lackluster/nonexistant support for Linux makes me consider sending it back while I still can.
I wondered whether some of you here in the forum might have some experience with the device or generally have recommendations where I can look for fixes. The major issues are:

  • Screen brightness is not adjustable (keys work, but do nothing)
  • Speakers are not adjustable (when turning down the volume the speakers get muffled but not quieter. Once the audio is at 0% they turn off. Headphones are just fine)
  • Bttery life is very poor, though it might just be it being stuck on max-brightness, having the GPU on, all cores at full frequency. Haven’t played around with TLP yet

Any hints or tips are welcome. I already looked at the ROG-Core utility on github, and am currently trying to get it working properly. It says that some kernel patches are needed on that specific device, which is something I’ve never done before so at least I’m looking forward to learning something new.
Thanks and maybe the G14 owners and simulateneous Linux-enthusiasts can come together and get this thing working properly. It sure would be great considering the otherwise great device the G14 is.

1 Like

I am not an owner of that laptop, but I am willing to help where I can.
First off though, what distribution are you running and what is your kernel version?

Currently I’ve not gotten around to playing around with i a lot. It’s Ubuntu with Kernel 5.6 since from what I’ve read that seems to be most stable so far. That information might be outdated though so my current plan is to get Manjaro on it and apply some of the custom kernel patches recommended on the rog-core Github repo.
Thanks for being willing to help, I greatly appreciate it! I hope this can evovle to a thread where eventually people who want to use that machine can get all they need in one place :smiley:

yes, and then you could come back to us and say how it’s going

generally this is where linux gets fucked up… new hardware generally comes locked down and takes a while for our open source heroes to get around, even more when it comes to laptops

Well yeah that’s the idea haha

Well, first try using the latest mainline kernel. They can be found here. If that doesn’t work, try using the latest release candidate, denominated with rc.

Just for curiosity I tried leaving xmp on. Almost worked, actually.

I think I’ll just adjust the timings… Or leave it alone lol